Indian Motorcycle Forum banner
1 - 5 of 5 Posts

·
German Rider
Joined
·
2,142 Posts
Maybe KILOMETER instead of miles.

Cu,
Sven
 
  • Like
Reactions: Arte

·
Rider
Joined
·
1,718 Posts
Correct! Change the setting to miles and you will have ‘mi’ displayed.
 
  • Like
Reactions: Arte
1 - 5 of 5 Posts
Top