Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of August's Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Indian scout sixty 2016 RED
Joined
·
9 Posts
Discussion Starter · #1 ·
So i keep trying to clean my bike every 3 days because of the salt on the roads in the UK. (Having to use my baby as my work bike at the moment).
The problem i got this week was on Wednesday morning it failed to catch the ignition so my battery drained and had to charge then tonight leaving work it struggled to start and now my full beam is on dim but the blue lamp indication doesn’t light up.

the blue light lights up when i turn the key and flip the switch but not when i hit full beam???

im thinking either my battery is buggered or maybe the alternator is the culprit. Then again i have a bad rear abs which the part has yet to arrive for a repair so maybe a current discharge is happening??

it is going for a mid winter service next week that may end up as a repair + service job now.
Any thoughts would be much appreciated as im not exactly mechanically minded but know the basics.

indian scout sixty 2016
13000miles on clock
currently the uk mornings are icy patch roads at 5:30am
 

·
Registered
2021 Scout Bobber 60
Joined
·
156 Posts
If the battery was drained when you left you ignition on, it i most likely time for a new battery. Draining and lead acid battery fully kills them (I've done it before, I know). Not sure about across the pond, but over here most auto parts stores will test it for free if you take it out of the bike and bring it in.
 

·
Registered
Indian scout sixty 2016 RED
Joined
·
9 Posts
Discussion Starter · #3 ·
If the battery was drained when you left you ignition on, it i most likely time for a new battery. Draining and lead acid battery fully kills them (I've done it before, I know). Not sure about across the pond, but over here most auto parts stores will test it for free if you take it out of the bike and bring it in.
I did accidentally leave my lights on with the bike in kill switch mode before Christmas because i had an emergency at home and just forgot to check my bike afterwards until nightfall. And on Monday my bike struggled to catch that it drained the battery down. So i think i have a bad battery.

as for my high beam i think the high beam element might have gone as the blue dash light works on key turn start up but not when i flip the switch. Just a very dim light (actually dimmer then the main light).

its been a very annoying winter as my tax & insurance was in early January and my abs issue is still waiting to be fixed. We dont have many indian motorcy dealerships in the UK so my closest is over 2 hours away. Slightly regretting m purchase but at the same time i love my bike.
 

·
Registered
Joined
·
293 Posts
Your high beam element is likely out. The reason you get the dim light is because the scout has a parking light that’s always on, in addition to the headlight bulb, with both low and high beam.
 

·
Registered
Indian scout sixty 2016 RED
Joined
·
9 Posts
Discussion Starter · #5 ·
Thanks for all the replies. It turned out to be a switch problem with the high beam. Getting a new battery this week also.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top