Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
616 Posts
Discussion Starter · #1 · (Edited)
I noticed my speedo having a surge a few days ago, and now I'm basically going 0 or 60. There is a huge lag when I slow down, but it seems when I speed up it jumps to 60 really quick.

How does the speedo work? Is it based off RPM and gear, or something else? I assume it's calculated in the ECU. Is there a way to reset it?

I currently am running the factory stage 1 flash for intake and exhaust for 2 years now. Nothing new or recent.
 

·
Registered
Joined
·
146 Posts
My brother just went thru this on his 2019 Scout ABS and it was a bad speed sensor. It can be reset but they tried that and it happened again so they replaced it under warranty.
 

·
Registered
Joined
·
563 Posts
My Wife's bobber had this same issue - entire "dash" had to be replaced - thankfully under warranty. The best part: she got ZERO miles on the bike again lol
 

·
Bronze member
Joined
·
5,097 Posts
My 2016 Scout did exactly as you described when it was barely a year old. It would show 60 to 80 kph as I changed into 2nd coming away from lights in traffic.

It got so I could accelerate quickly and the needle would rise way too much, and I'd decelerate slowly and it wouldn't come down. I did that several times in a 70 kph zone and got the needle almost around to the zero point without me going over the speed limit.

The problem is the speedo itself. Mine was replaced under warranty. As noted, the odometer goes back to zero.

Somewhere there's my forum post about it - back about Aug/Sept 2017 I think. There have been several members with the same problem.
 
1 - 5 of 5 Posts
Top