Indian Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
my 2016 Roadmaster has stage 2 set up. I have read that the idle is set around 750. My bike seems to idle so low that it can and sometimes does stall. I have read other’s posts who like to lope of the low idle speed. However, I am the exact opposite. I want a smooth clean idle like my Victory XCT used to have. Is there any way to raise the idle a bit or does it have to be done in the ECM settings?
 

·
Registered
Joined
·
8,005 Posts
my 2016 Roadmaster has stage 2 set up. I have read that the idle is set around 750. My bike seems to idle so low that it can and sometimes does stall. I have read other’s posts who like to lope of the low idle speed. However, I am the exact opposite. I want a smooth clean idle like my Victory XCT used to have. Is there any way to raise the idle a bit or does it have to be done in the ECM settings?
The stage 2s will have a lope in them. Its what they do to the intake and exhaust valves.

How low is your idle? When I had the stage 2s it woukd jump back and forth between like 800 and 1100. It really jumps around with the stage 3 cams on my now 116. If you want a flat smooth idle, you'll need to switch back to factory originals.

Now, I think 750 is a bit low. Should be 800 to 850 at the bottom.

You need to enlist the opinions of @RACNRAY or @CraigB1960 .
 

·
Bronze member
Joined
·
2,104 Posts
750 RPM is what mine idles at once she's up to temp and has been that way since new.When first started,cold,she jumps to 900 or alittle more,but gradually drops back to that 750 rpm mark,usually bouncing between 750 and 800 rpm.But mine is bone stock,no mods.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
The stage 2s will have a lope in them. Its what they do to the intake and exhaust valves.

How low is your idle? When I had the stage 2s it woukd jump back and forth between like 800 and 1100. It really jumps around with the stage 3 cams on my now 116. If you want a flat smooth idle, you'll need to switch back to factory originals.

Now, I think 750 is a bit low. Should be 800 to 850 at the bottom.

You need to enlist the opinions of @RACNRAY or @CraigB1960 .
I am only going by the tachometer, but it hovers around the half way point between 500 and 1000 rpms. So i have to assume it is around 750. But periodically, when I am coming off the throttle to stop, it will initially drop to 1000, then just stall.!It always starts right back up. But it is annoying.
 

·
Registered
Joined
·
527 Posts
You may have intake leak, exhaust leak or a faulty sensor that's has gone into default mode not causing a check engine light.
Worth a look into if your under warranty

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Thanks for all the replies and input. I took a nice long ride yesterday and only had one issue. I'm taking the bike to the dealer to have it checked. I was getting gas and started the bike. It was idling around 750, fully warmed up, and suddenly it backfired super load, no throttle input from me, just idling, then it shut off. When I tried to restart, it would not fire. I turned everything off and back on and it started and ran fine for 200 plus miles. So I'm convinced something in wrong, so I'm calling for an appointment tomorrow.
 

·
Registered
Joined
·
218 Posts
@Bikerbill64: what was the resolution for this issue? I’m running into similar problems re: low idle stall (additionally it won’t restart in 1st; need to switch to neutral to start.)

Thanks in advance.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
264 Posts
I've had a stall once where loose header bolts were the culprit. The loss of exhaust pressure caused this. Tightened it up and no problem since.
 
1 - 9 of 9 Posts
Top