Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

21 - 40 of 75 Posts

·
Rider
Joined
·
517 Posts
Are the issues with Ride Command with every Challenger?


Sent from my iPad using Tapatalk
I don't think so. I haven't experienced any of the above issues with mine.
 

·
Registered
Joined
·
3 Posts
I have issues with mine too. Loads slow, plugging the iPhone in works when it wants to, night mode to day mode etc is flakey, and in the operational screens you can move the widgets to customize your screen, this only works for that ingnition cycle and then they revert back. It’s honestly my least favorite thing about my challenger.
 

·
Registered
Joined
·
2,025 Posts
Interesting. Is it because some are different software versions, or some were upgraded (didn’t have nav and cellular)and features were added later? Are issues only found mainly on the Challenger models or are all 2020 models having issues?


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
3 Posts
Idk honestly when I bought it it needed and update. So I downloaded and installed the latest which I believe was a January release. I had hoped it would resolve some of the issues but it did not. I haven’t added NAV yet.
 

·
Registered
Joined
·
107 Posts
My bike has not connected to Ride Command since day 1- I kept telling them it was the modem with no one listening. Finally I made them run diagnostics on the modem- No data transmitting or received by the modem. Now I am trying to get them to send a replacement modem to my local dealer for warranty install...
 

·
Rider
Joined
·
517 Posts
I have issues with mine too. Loads slow, plugging the iPhone in works when it wants to, night mode to day mode etc is flakey, and in the operational screens you can move the widgets to customize your screen, this only works for that ingnition cycle and then they revert back. It’s honestly my least favorite thing about my challenger.
Unless you have the GPS modem, the widgets won't save. It is supposed to be fixed in the next update. They are aware of the issue, but it doesn't hurt to reach out to them, the whole "Squeaky wheel" thing
 

·
Registered
Joined
·
79 Posts
Here is my problem with the Ride Command...... When the phone is connected via bluetooth, the navigation does not work...
 

·
Registered
Joined
·
8 Posts
Interesting! I have the exact same message ”error calculating routes” although the routes have been imported. So maybe will try loading the route and then switching the Bluetooth back on. Does anybody have any info on when the much talked about update is arriving. I had a vague response from Polaris a month ago that it was coming sometime this summer.
 

·
Registered
2020 Indian Challenger
Joined
·
1,290 Posts
It was supposed to have been May but has been pushed from what I've seen.
 

·
Registered
Joined
·
2,025 Posts
Wondering why this is showing up in the Challenger only? Does it use a different Ride Command system than all the other bikes? And if so why?


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
10 Posts
I would prefer to back rev mine to the older version! This "new" ride command has no where near the features or accuracy of the previous version.
 

·
Bronze member
Joined
·
1,814 Posts
Interesting! I have the exact same message ”error calculating routes” although the routes have been imported. So maybe will try loading the route and then switching the Bluetooth back on. Does anybody have any info on when the much talked about update is arriving. I had a vague response from Polaris a month ago that it was coming sometime this summer.
what if you connect the USB /cable to the iPhone vs. Bluetooth?
 

·
Registered
Joined
·
184 Posts
My bike has not connected to Ride Command since day 1- I kept telling them it was the modem with no one listening. Finally I made them run diagnostics on the modem- No data transmitting or received by the modem. Now I am trying to get them to send a replacement modem to my local dealer for warranty install...
Same problem here.
Please keep us updated if the new modem makes a difference.
 

·
Registered
Joined
·
565 Posts
I've been fortunate. No issues with GPS and nothing consistent with weird screens. Yes I have had an occasional glitch, and yes there is no excuse why it doesnt work with the same almost 100% consistancy as my Chevy truck, but I do find all the toggle screens entertaining. I have figured out what sets off some of the bizarre behaviour and now know the weird protocols that have to be followed to minimize them. It shouldn't have to go that way..they need to hire an engineer from an auto manufacturer to either fix the programming or use a more stable platform. The smoke effect is cool but is just not necessary along with the overly complicated sensor system that creates the glitches. Someone at Indian has been choosing features over function for several years.
 

·
Registered
Joined
·
565 Posts
I'm pretty sure the USB port just charges the phone. It an also access music. But the phone has to be bluetoothed. New alls come in and call history shows up, as well as text notifications. At least on mine. Look at you settings me he on you phone.
 

·
Registered
Joined
·
79 Posts
I'm pretty sure the USB port just charges the phone. It an also access music. But the phone has to be bluetoothed. New alls come in and call history shows up, as well as text notifications. At least on mine. Look at you settings me he on you phone.
Yes, I am aware of the phone via bluetooth.....I was responding to the question by another member regarding the bluetooth vs USB.
 

·
Registered
Joined
·
565 Posts
In My opinion is, the usb connector is only good for charging the phone, uploading ride command updates, and plugging in a separate mp3 player. Phone should be blue toothed.
 

·
Registered
Joined
·
156 Posts
Bought my Challenger in November.
And just recently the usb would not recognize my phone but still keeps it charged.

Yes everything works via Bluetooth except I don’t see the icons for replay or shuffle anymore but everything use to work when hooked with usb.

I just had the recall done for the throttle bodies, I wonder if they also do a ride command reflash/update?
I also tried different adapter cords for phone.
 
21 - 40 of 75 Posts
Top