Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Just got a new Challenger, when I drag widgets like the garage door opener over to the screen and click done it is on the screen until I shut the bike off. When I start it up, the screen goes back to the default and I loose the widget I customized. Any suggestions?
 

·
Registered
Joined
·
77 Posts
Mine does the same thing. Apparently we are too cheap because we got the base mode. Lol! people who bought Nav don’t have this problem. I made a complaint to Polaris about it. Waiting to see what they say.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
90 Posts
I have the same issue with my base purchased 11/23/19. Polaris is working on update was there answer in December 2019. So still waiting.
 

·
Registered
Joined
·
134 Posts
My base 20 Chieftain has the same issue. I kinda gave up trying. I dont have the TPMS either. But its ok with me. Didnt feel like spending almost 30k for a DH or limited
 

·
Registered
Joined
·
112 Posts
Just got a new Challenger, when I drag widgets like the garage door opener over to the screen and click done it is on the screen until I shut the bike off. When I start it up, the screen goes back to the default and I loose the widget I customized. Any suggestions?
Velcro the door opener remote to the side of the dash and dare it to disappear...lol :p
 
1 - 8 of 8 Posts
Top