Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 20 of 22 Posts

·
Premium Member
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey everyone I just had the recall done and the dealer did the ECM flash. I have a 2018 Springfield Dark Horse. Now, the front and rear PSI reading does not show up in the data mode. I went back to the dealer and they re-did the TPS sync and it still does not show up. The dealer says they have to call Polaris monday to see if they took it out as part of the tune update. Anyone else have this problem?
 

·
Registered
Joined
·
21 Posts
I haven’t had mine done yet but I work at the KC dealer and we’ve had zero problems with the reflash. Maybe They had a corrupted file or something.
 

·
Founding Member / Distinguished
Joined
·
4,508 Posts
I haven’t had mine done yet but I work at the KC dealer and we’ve had zero problems with the reflash. Maybe They had a corrupted file or something.
Hey Logan what do you do at the dealership ?


Sent from my iPad using Tapatalk
 

·
Rider
2017 Springfield
Joined
·
975 Posts
Hey everyone I just had the recall done and the dealer did the ECM flash. I have a 2018 Springfield Dark Horse. Now, the front and rear PSI reading does not show up in the data mode. I went back to the dealer and they re-did the TPS sync and it still does not show up. The dealer says they have to call Polaris monday to see if they took it out as part of the tune update. Anyone else have this problem?
Nick, you might have gotten the flash that moved the TPMS reading to the right trigger. I have not had that flash yet on my 2017, so it is still on the left trigger. Check to see if that works. Personally, I am going to have to rewire my trigger because it is currently controls my garage door opener.

Good luck.
 
  • Like
Reactions: CSpaR

·
Registered
Joined
·
13 Posts
Hey everyone I just had the recall done and the dealer did the ECM flash. I have a 2018 Springfield Dark Horse. Now, the front and rear PSI reading does not show up in the data mode. I went back to the dealer and they re-did the TPS sync and it still does not show up. The dealer says they have to call Polaris monday to see if they took it out as part of the tune update. Anyone else have this problem?
It does not show up when you select the toggle on the right? It moved from w/in the options on the left toggle to the right side with the new flash...or at least should have.

Sent from my SM-N975U using Tapatalk
 

·
Premium Member
Joined
·
10 Posts
Discussion Starter · #7 ·
Thank you everyone for the input. The fix was using the toggle switch on the right. For Springfields this is not normally enabled.

So, after the update which will be done by the dealer for the recall the PSI mode will be moved to the right toggle switch.
 

·
Registered
Joined
·
476 Posts
I'm amazed the dealer didn't know this. Wow. It wasn't a Ride Now dealership, was it? They hire kids out of the local motorcycle tech schools, who know nothing about Indians. I got my Scout from one of them and I wouldn't go back. Just got a new Springfield from an independent dealer and they gave me run-down before taking it home. They even flashed it and took care of the recall before I picked it up. (It was a new 2019).
 

·
Registered
Joined
·
374 Posts
I just called to attempt to schedule mine and they told me the flash was corrupted and until Indian fixed that they were not doing anymore of the recalls. I would be suspicious if it were anybody else, but this was at Gregory Polaris out of Little Rock.
 

·
Registered
Joined
·
476 Posts
I just called to attempt to schedule mine and they told me the flash was corrupted and until Indian fixed that they were not doing anymore of the recalls. I would be suspicious if it were anybody else, bu this was at Gregory Polaris out of Little Rock.
This is weird. I just picked up my bike, going on two weeks ago, and they did the recall work before I picked it up. Why wouldn't your dealer have the same info?
 

·
Registered
Joined
·
312 Posts
Hey everyone I just had the recall done and the dealer did the ECM flash. I have a 2018 Springfield Dark Horse. Now, the front and rear PSI reading does not show up in the data mode. I went back to the dealer and they re-did the TPS sync and it still does not show up. The dealer says they have to call Polaris monday to see if they took it out as part of the tune update. Anyone else have this problem?
I have mine scheduled for Saturday I'll post an update when completed?
 

·
Registered
Joined
·
374 Posts
This is weird. I just picked up my bike, going on two weeks ago, and they did the recall work before I picked it up. Why wouldn't your dealer have the same info?
I don't know, and they aren't my local dealer, I just prefer them and was going to make a weekend trip out of it. I may call one a little closer just to see if they say the same thing.
 

·
Registered
Joined
·
46 Posts
Had my recall done this last week and got my bike back yesterday. Love the psi is moved over to the right trigger switch and the fact on the 3rd press it goes back to the last reading before you flick through your psi. Very possible it's my imagination, but the bike seems to be running even better....yeah, that's prob all in my head. Love this bike.
 

·
Bronze member
Joined
·
4,325 Posts
Had my recall done this last week and got my bike back yesterday. Love the psi is moved over to the right trigger switch and the fact on the 3rd press it goes back to the last reading before you flick through your psi. Very possible it's my imagination, but the bike seems to be running even better....yeah, that's prob all in my head. Love this bike.

Not necessarily in your head. Depending on the year of your bike, Indian also re-flashed the ECU tune on bikes that had outdated versions.
 

·
Registered
Joined
·
8 Posts
Hey everyone I just had the recall done and the dealer did the ECM flash. I have a 2018 Springfield Dark Horse. Now, the front and rear PSI reading does not show up in the data mode. I went back to the dealer and they re-did the TPS sync and it still does not show up. The dealer says they have to call Polaris monday to see if they took it out as part of the tune update. Anyone else have this problem?
Hi, check the right side handlebar trigger. That's where mine went.
 

·
Registered
Joined
·
2 Posts
Hey everyone I just had the recall done and the dealer did the ECM flash. I have a 2018 Springfield Dark Horse. Now, the front and rear PSI reading does not show up in the data mode. I went back to the dealer and they re-did the TPS sync and it still does not show up. The dealer says they have to call Polaris monday to see if they took it out as part of the tune update. Anyone else have this problem?
Yes. Same problem 2017 Springfield
 
1 - 20 of 22 Posts
Top