Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just wired my Roadmaster for a trailer and now my rear turn indicators stay lit for 45 seconds before turning off. What did I do wrong?
 

·
Registered
Joined
·
569 Posts
Same thing happens when you add an Admore light to the circuit. I’ve read something about the impedance in the circuit is dissipating, if I remember correctly.
 

·
Registered
Joined
·
2,677 Posts
IIRC, with the lightbar there is a capacitor in the bar that keeps the turn signals lit as it discharges, due to how the bar is wired. It is probably the same with your trailer.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
IIRC, with the lightbar there is a capacitor in the bar that keeps the turn signals lit as it discharges, due to how the bar is wired. It is probably the same with your trailer.
So nothing wrong and I’ll just have to live with?
 

·
Premium Member
Joined
·
290 Posts
Huh. I have an Admore light bar on my Roadmaster and the lights turn right off after shutting down. Also looking at adding a trailer at some point. Which harness did you go with?
 

·
Bronze member
Joined
·
1,982 Posts
It happens because for some stupid reason Indian decided to use ground instead of the hot wire to control the turn signals.
 

·
Registered
Joined
·
8 Posts
Did you install the Custom Dynamics Load Isolator? I had an issue when installing mine and the problem was just that a wire on the input side did not have enough wire stripped back when it was manufactured. Check all input wires for proper contact.
 
1 - 9 of 9 Posts
Top