Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
101 - 120 of 131 Posts

·
Registered
Joined
·
70 Posts
So, I finally got my lights "activated". It appears there may have also been a software update, if I am reading correctly. Meaning, my lights stay on (even after shutting the bike down) even after putting it in gear. In short, if they were on when I shut my bike off, they come on when I turn it back on (and off if they were off). They work, how I would expect. They were "activated" 8/27/21.

Sent from my SM-G996U using Tapatalk
 

·
Registered
2020 Challenger Limited Deepwater
Joined
·
12 Posts
Same here. After a month of troubleshooting, replaced the control module 3 and poof!...all worky.
 

·
Registered
Joined
·
22 Posts
So, I finally got my lights "activated". It appears there may have also been a software update, if I am reading correctly. Meaning, my lights stay on (even after shutting the bike down) even after putting it in gear. In short, if they were on when I shut my bike off, they come on when I turn it back on (and off if they were off). They work, how I would expect. They were "activated" 8/27/21.

Sent from my SM-G996U using Tapatalk
Just got mine installed last month. And if they are on when I turn bike off they come back on when it’s started next.
 

·
Registered
2020 Indian Challenger
Joined
·
1,542 Posts
What I've noticed. If the lights are on when the bike shuts off, they turn on when the bike turns on. Once I shift from Neutral to 1st, they shut off. If I leave the bike in 1st and start with the clutch pulled in, they stay on.

AzRocket, are you saying that if you have them on in N and shift to 1st they stay on?
 

·
Registered
Joined
·
22 Posts
What I've noticed. If the lights are on when the bike shuts off, they turn on when the bike turns on. Once I shift from Neutral to 1st, they shut off. If I leave the bike in 1st and start with the clutch pulled in, they stay on.

AzRocket, are you saying that if you have them on in N and shift to 1st they stay on?
Mine stay on shifting from N to 1st
 

·
Registered
Joined
·
70 Posts
What I've noticed. If the lights are on when the bike shuts off, they turn on when the bike turns on. Once I shift from Neutral to 1st, they shut off. If I leave the bike in 1st and start with the clutch pulled in, they stay on.

AzRocket, are you saying that if you have them on in N and shift to 1st they stay on?
Yep. I have them on at start, they stay on even after shifting from N to 1st. They will only shut off, if I hit the button to shut them off.

Sent from my SM-G996U using Tapatalk
 

·
Registered
Joined
·
276 Posts
What I've noticed. If the lights are on when the bike shuts off, they turn on when the bike turns on. Once I shift from Neutral to 1st, they shut off. If I leave the bike in 1st and start with the clutch pulled in, they stay on.

AzRocket, are you saying that if you have them on in N and shift to 1st they stay on?
I noticed that mine works the same as this. The only time I've seen it work differently is at dusk. They seem to stay on if the light is low or it's dark.
 

·
Registered
2020 Indian Challenger
Joined
·
1,542 Posts
Good to know. I had my VCM programmed in March so maybe there was an update that fixed it. It's so annoying, I opened a case with Polaris and they never let me know.
 

·
Registered
Joined
·
276 Posts
I had mine programmed around the same time. I have a state inspection I’m getting done today, so I will ask for any updates and get back to you.
 

·
Registered
2020 Indian Challenger
Joined
·
1,542 Posts
Awesome, thanks!!
 

·
Registered
Joined
·
2 Posts
I recently purchased the Pathfinder S LED Driving Light Mount Kit and the Indian LED 3.5" lights sold separately for my Challenger Limited. I'm located in Texas, purchase the LED driving lights from Indianmotorcycle.com and the driving light mount kit online from a dealership in Arkansas. After installing everything I noticed that the driving light switch was illuminated as soon as I powered up the bike but the button switch doesn't seem to work properly, when I push the button switch the light does not shut off and the driving lights won't come on no matter how many times I re-push the button switch. I had the installation instructions which are now on line for the Challenger, the install is easy but somewhat time consuming. When the driving lights would not work, I disassembled the entire system and rechecked every step of the install three times, even checked the electrical pins for any possible damage but the driving lights still would not come on. All of the other lighjts work fine so I then went on to check the fuse box and all of the fuses where good as well. Afterwards I seen that I had a "Notice" on the RideCommand and it was for the driving lights but there wasn't any specific code nor description other than "Unkown Error" Unhandled error code SPN: 516194 FMI:9 SrcAddr:145 on the ride Command screen. I guess on Tuesday I'll will call the dealership to see if they have any experience with this kit and install, otherwise I'm going to need to take it to my local dealership to see if they can get to the bottom of this problem. Anmyone else install these on their Challanger?

View attachment 610611

Behind the rubber sleeve inside the left hand glove box are three separate connectors, a two pin , a three pin and a four pin (all female connectors). The driving light button switch has a (male plug) four (4)-pin connector so there's no question of which one is correct to use. This is also explained in the installation instructions. The reason I believe the problem is with the switch is that when you try to depress the driving light button swtich the light on the switch will not shut off. The instruction said it is only is used to turn on and off the driving lights so when you shut them off the lighted swtich is suppose to be off as well but mine won't shut off and stays illiminated constantly when the bike is powered up.

See page 9 of 13 on the installation manual:
https://cdn1.polaris.com/globalasse...2/New/2884899_kit_instructions.pdf?v=870ebafa
I recently purchased the Pathfinder S LED Driving Light Mount Kit and the Indian LED 3.5" lights sold separately for my Challenger Limited. I'm located in Texas, purchase the LED driving lights from Indianmotorcycle.com and the driving light mount kit online from a dealership in Arkansas. After installing everything I noticed that the driving light switch was illuminated as soon as I powered up the bike but the button switch doesn't seem to work properly, when I push the button switch the light does not shut off and the driving lights won't come on no matter how many times I re-push the button switch. I had the installation instructions which are now on line for the Challenger, the install is easy but somewhat time consuming. When the driving lights would not work, I disassembled the entire system and rechecked every step of the install three times, even checked the electrical pins for any possible damage but the driving lights still would not come on. All of the other lighjts work fine so I then went on to check the fuse box and all of the fuses where good as well. Afterwards I seen that I had a "Notice" on the RideCommand and it was for the driving lights but there wasn't any specific code nor description other than "Unkown Error" Unhandled error code SPN: 516194 FMI:9 SrcAddr:145 on the ride Command screen. I guess on Tuesday I'll will call the dealership to see if they have any experience with this kit and install, otherwise I'm going to need to take it to my local dealership to see if they can get to the bottom of this problem. Anmyone else install these on their Challanger?

View attachment 610611

Behind the rubber sleeve inside the left hand glove box are three separate connectors, a two pin , a three pin and a four pin (all female connectors). The driving light button switch has a (male plug) four (4)-pin connector so there's no question of which one is correct to use. This is also explained in the installation instructions. The reason I believe the problem is with the switch is that when you try to depress the driving light button swtich the light on the switch will not shut off. The instruction said it is only is used to turn on and off the driving lights so when you shut them off the lighted swtich is suppose to be off as well but mine won't shut off and stays illiminated constantly when the bike is powered up.

See page 9 of 13 on the installation manual:
https://cdn1.polaris.com/globalasse...2/New/2884899_kit_instructions.pdf?v=870ebafa
hello there Herk. I have installed those light on my 2020 challenger limited. After I installing the lights, you have to take it to the dealership to flash the ECU. It’s half hour labor $60…I found this process out via YouTube so I knew I had to take it to the shop post install.
 

·
Registered
2020 Challenger...Sandstone Smoke
Joined
·
489 Posts
I see there have been some problems with these lights with missing parts, installs, and having to activate them but after all is said and done was it worth it? How do they perform and does anyone have any pics of them at night on a dark road both with lights on and off to see a comparison? Just looking at options and don't know if I should order these or go aftermarket...thanks
 

·
Registered
2020 Indian Challenger
Joined
·
1,542 Posts
I love them! I think they look good and they're mounted well. I can see both sides of the ditches when I ride. I make sure I aimed them properly, along with my headlight and I think they're better than my car. I also have aftermarket lights on as well but they're mounted a lot lower and a different color. Between the 2, I'm about a safe as I can be from the front.
 

·
Registered
2020 Challenger...Sandstone Smoke
Joined
·
489 Posts
I love them! I think they look good and they're mounted well. I can see both sides of the ditches when I ride. I make sure I aimed them properly, along with my headlight and I think they're better than my car. I also have aftermarket lights on as well but they're mounted a lot lower and a different color. Between the 2, I'm about a safe as I can be from the front.
Thanks for the input...I'm between ordering the Indian lights or these...any pics at night for a comparison between on and off?

 

·
Registered
2020 Indian Challenger
Joined
·
1,542 Posts
I don't have any sorry. I can try to take some but it'll be a while.
 

·
Registered
Joined
·
276 Posts
I didn’t get to talk to the Tech, however, the service advisor told me the 2021 will stay in the last switch position when the bike is shut off. She didn’t know if the 2020 can be flashed to do the same. The Tech was on a ride to check another fellas bike. I asked her to ask the Tech and give me a call or text once she finds the answer.
 

·
Registered
Joined
·
37 Posts
Just got a call from my dealer today and there is a flash update to fix the lights shutting off when put into gear. I called them yesterday and they weren’t aware of the update so I had him call Indian to check. It’s pretty screwy that I opened a ticket with Indian and they told me that a fix was coming but I had to check with my dealer to see if it is available. Then, Indian not informing the dealerships that the fix is available.
 

·
Registered
Joined
·
276 Posts
Someone asked about the lights at night. Let me see if I can post them. First one is on, second is off. Glad I had them, saw a big deer on another road I was on and not sure I would have seen him without. The Eagle light helps a lot too.
Plant Car Automotive lighting Vehicle Speedometer
Plant Car Vehicle Speedometer Automotive lighting
 
101 - 120 of 131 Posts
Top