Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
Took my Roadmaster in for the 500 mile check and oil change. When I was getting ready to leave the technician had me look at the MFD for percentage of oil life left and it read, "Change Oil Now". He said he noticed this too after changing the oil and resetting it to 100%. So he showed me how to reset it too but after shutting off the engine it always comes back to "Change Oil Now". He said he was going to contact Indian/Polaris about this issue so I wondered if any others have experienced this problem.

George from WI.
"kulczge"
 

·
Registered
Joined
·
1,157 Posts
Took my Roadmaster in for the 500 mile check and oil change. When I was getting ready to leave the technician had me look at the MFD for percentage of oil life left and it read, "Change Oil Now". He said he noticed this too after changing the oil and resetting it to 100%. So he showed me how to reset it too but after shutting off the engine it always comes back to "Change Oil Now". He said he was going to contact Indian/Polaris about this issue so I wondered if any others have experienced this problem.

George from WI.
"kulczge"
I'll keep an eye out for the problem, not at 500 quite yet.

Maybe disconnect the battery for a bit and see if that resets? We have to remove the trunk to remove the seat to get at the battery I hear.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #3 ·
A couple times after I did the reset it showed 100% and later 99% but it reset again to "Change Oil Now". I am attending a local Indian group rider meeting tomorrow at the dealership location and will ask about this issue. Also waiting to hear back from the service rep.
 

·
Registered
Joined
·
354 Posts
I have this problem on my 2015 Chieftain. The tech told me he would have to reflash the ECM. Haven't had time to go back in so I'm at 880 and still trying to reset with no luck. I'll get to the dealer this weekend and see if the reflash works. Update to follow.
 

·
Registered
Joined
·
355 Posts
To re-set, hold left trigger until change oil starts flashing, then release and pull in trigger again until you see 100%...good luck...
 

·
Registered
Joined
·
114 Posts
Took mine in yesterday for the 500 mile service. Had to wait another 30 minutes for them to download new software to fix this issue. I noticed earlier that I could not reset the average MPG. The download fixed that too.
 

·
Registered
Joined
·
5 Posts
Talked with the mech at my local dealer and he said this is a known bug in the Roadmasters and they are seeing it with the Chieftains as well. Mother Indian is working on a software upgrade but has not released it yet. There doesn't seem to be any side effects otherwise that they mentioned, hopefully there will be an update in the new year.
 

·
Registered
Joined
·
5 Posts
hmmm, dealer tech said yesterday that it wasn't available. Maybe they are working one up a patch to deal with stuff specific to the Chieftain. He mentioned they knew about the Roadmaster's for a while. Good to know they got yours fixed with a software update.
 

·
Registered
Joined
·
191 Posts
The Dealer had a new flash and it fixed the issue.
 
1 - 13 of 13 Posts
Top