Indian Motorcycle Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
First time doing an oil change not using the Indian kit because the price has gone up so much it was cheaper to buy Amsoil by the quart. Went with the HiFlo HF175 filter. Got everything done and when I start the bike it pukes oil out of the filter. Thought maybe I didnt tighten enough so gave it another turn and tried again and the same. No matter how much I tighten it still leaks out of the filter. Anyone have experience with this filter? Am I doing something wrong? Looking at it the gasket seems different than the stock Indian filter (HiFlo has a rib to it while the stock is flat) but it's listed as compatible on their site so not sure what's going wrong here.
 

·
Bronze member
Joined
·
3,451 Posts
First time doing an oil change not using the Indian kit because the price has gone up so much it was cheaper to buy Amsoil by the quart. Went with the HiFlo HF175 filter. Got everything done and when I start the bike it pukes oil out of the filter. Thought maybe I didnt tighten enough so gave it another turn and tried again and the same. No matter how much I tighten it still leaks out of the filter. Anyone have experience with this filter? Am I doing something wrong? Looking at it the gasket seems different than the stock Indian filter (HiFlo has a rib to it while the stock is flat) but it's listed as compatible on their site so not sure what's going wrong here.
I use HiFlo filters on all of my bikes and have never had an issue. But I don’t have a Challenger so I cannot help you out there.
 

·
Bronze member
Joined
·
1,973 Posts
I sell ONLY Hiflo filters and have found them to beo f excellent quality but as with anything there is also defects in material and workmanship or improper installation. As was said if ur skoot has the puddle lite it's wire come awfully close and can be pinched, also it is not uncommon for the oring seal from the original filter to stick to the block, make sure it is not there and in the old filter.

RACNRAY
 
  • Like
Reactions: Baron58

·
Registered
Joined
·
65 Posts
Discussion Starter · #6 ·
Well pulled while I had the filter off I double checked and made sure the gasket was sitting in the groove correctly. Cleaned up the neck and surrounding area and put it back on. Normal tight again. This time no leaks. Not sure if the wire for the puddle light is there or not on a base model. Definitely not a double gasket issue. Whatever it was seems to be fixed now. Had to top off about another quart for what was lost. Just had me nervous since this was the first time not using the Indian kit I was hoping I didn't screw something up.
 
1 - 6 of 6 Posts
Top