Indian Motorcycle Forum banner

1 - 10 of 10 Posts

·
Rider
Joined
·
710 Posts
Discussion Starter #1
I bought one of your black horns back in March of 2018 (installed on March 24th) and I have been extremely happy with it. My only disappointment was that I wish I had gotten the long horn instead of the short one, but that's my fault, not yours ! ! !

Anyway, I was riding to work this morning and the car in front me was just sitting after the light turned green, so I figured I wake him up. But when I hit the horn button . . . nothing.

I tried it several times during the ride in to work and I could hear something vibrating or whirring. When I got home, I tried it again and I heard the same thing, but again no horn.

I took a short video of the horn, it should be attached as a zip file.

I assume that I'm still covered under the warranty. I'm not much of a mechanic anymore (son-in-law did the installation). Do I need to dismantle it and send it back or will the video be enough. If so, can a pay the difference and get the longer horn this time?





BD
 

Attachments

·
Registered
Joined
·
220 Posts
I bought one of your black horns back in March of 2018 (installed on March 24th) and I have been extremely happy with it. My only disappointment was that I wish I had gotten the long horn instead of the short one, but that's my fault, not yours ! ! !

Anyway, I was riding to work this morning and the car in front me was just sitting after the light turned green, so I figured I wake him up. But when I hit the horn button . . . nothing.

I tried it several times during the ride in to work and I could hear something vibrating or whirring. When I got home, I tried it again and I heard the same thing, but again no horn.

I took a short video of the horn, it should be attached as a zip file.

I assume that I'm still covered under the warranty. I'm not much of a mechanic anymore (son-in-law did the installation). Do I need to dismantle it and send it back or will the video be enough. If so, can a pay the difference and get the longer horn this time?


BD
Big Dawg,

Sounds like everything to and including the compressor is working properly.
There may be debris and/or water in the sounding unit. Either will not
allow the Lexan diaphragm to vibrate and properly sound.

There are 5 small screws that hold the two halves of the sounding
unit, the sounding unit is at the base of the trumpet.
Remove the 5 screws and clean the interior of the sounding unit and
diaphragm, then reassemble. You can unscrew the trumpet itself and
you’ll have easier access to the screws. That should restore the sound
and it should work properly.

If this doesn’t resolve the problem, please let us know and we’ll
trouble shoot further and do what we can to get it operating properly.

As for a 15" upgrade, we started using a different powder coating company and the black that is used now is more of a flatter black than before so I don't believe sending you just the trumpet and support arm would match your current System's sounding unit's coating.
If you'd like to send it in we can swap the horn out on your bracket and also go through your system to be sure it's working optimally.
We'll also include the new screened horn cover to help keep dirt/debris out and will help keep water out as well.
 

·
Rider
Joined
·
710 Posts
Discussion Starter #5
Hey Randy, so I followed your directions to the letter. Boy, that last screw, you know, the one just under, and next to, the bracket is a real PITA ! ! ! Fortunately, I had a Phillips on a ¼" drive with long extension.

There was no debris or moisture, so I put it all back together. Hit the button and it worked. I'm just curious now if it had "fixed itself"?

BTW, while I do ride in the rain if necessary, I don't recall any recent moist events, but who knows. As long as it's working now.

I would still like to explore switching out to the 15" trumpet, so feel free to put together what you think it would cost. Also, let me know what that screen runs so I can get one of them if the 15" swap doesn't work out.

You guys are the best ! ! !





BD
 

·
Registered
Joined
·
220 Posts
BD, I’ll let you know what the 15” upgrade is...
The cover would be no charge, gratis either way.
Hard to tell with the horn, if there’s anything that prevents the diaphragm from vibrating it won’t sound properly. Sometimes just hitting the button a few time will clear it... glad it’s working properly now.
All the best!
 

·
Rider
Joined
·
710 Posts
Discussion Starter #10 (Edited)
Randy & Kathy are the best ! ! !

As Randy mentioned, they changed the powder coating from gloss to flat and the upgrade to 15" was $70. But, like it was meant to be, they had one leftover gloss horn, but it had a blemish in the powder coating. I'll take it !

Even better, they had it to me in a few days for less than $30 ! ! !



Can you find the blemish ? ? ? (Neither can I ! ! )





BD
 
1 - 10 of 10 Posts
Top