Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 11 of 11 Posts

·
Registered
Joined
·
264 Posts
Discussion Starter · #1 · (Edited)
So after updating maps, and system, I powered up ridecommand, got same cycling on screen, but then I was pushing the left handle bar switch for options and...WAALAA!
EVERTHING WENT BACK TO NORMAL, yippie
Everything seems to be fine. Hope this helps someone. Ttyl. . Later Ryd.



Ok starting to get this ride command where I can negotiate the functions, but,,lol
In the navigation area, i put in address, then told it no tolls, no highways, then started trip, but its stuck on the cycling symbol..* anyways, shut bike off waited, then restarted..but it keeps restarting at same point..cycling..
How dominant stop this..I'm thinking batt..disconnect? Help! Lol lol
 

·
Bronze member
Joined
·
4,330 Posts
Ok starting to get this ride command where I can negotiate the functions, but,,lol
In the navigation area, i put in address, then told it no tolls, no highways, then started trip, but its stuck on the cycling symbol..* anyways, shut bike off waited, then restarted..but it keeps restarting at same point..cycling..
How dominant stop this..I'm thinking batt..disconnect? Help! Lol lol

What year bike? 2020 has a new ride command system compared to 2019 and earlier
 

·
Registered
Joined
·
264 Posts
Discussion Starter · #3 ·
Yes 2020..shut bike 2 times for about 30 mins, but still goes back to cycling ?. Nothing to reset, or stop on screen.
 

·
Registered
Joined
·
81 Posts
Ok starting to get this ride command where I can negotiate the functions, but,,lol
In the navigation area, i put in address, then told it no tolls, no highways, then started trip, but its stuck on the cycling symbol..* anyways, shut bike off waited, then restarted..but it keeps restarting at same point..cycling..
How dominant stop this..I'm thinking batt..disconnect? Help! Lol lol
That is probably one of the reasons the original owner took it back. Navigation system on the Challengers SUCK...! Let's hope they come up with an upgrade soon. Just use your phone.
You're lucky... I paid $500 for mine.
I noticed your saddlebags in your photo...mine had to have 2 new lids, they didn't close correctly. You might want to check that out too.
 

·
Bronze member
Joined
·
4,330 Posts
Late last year there was a lot of back and forth here on the forum about Indian releasing a new ride command system and there was a lot of people not happy that it would not be backwards compatible and that they would be left behind. Now they are most likely thinking, thank god we have the older system as it is pretty rock solid.
 

·
Registered
Joined
·
264 Posts
Discussion Starter · #9 · (Edited)
Ok,,gonna first try easy way,,software updates,and maps..if no fix to cycling , then pull main fuse..if not..dealer for answers? Lol
 

·
Registered
Joined
·
264 Posts
Discussion Starter · #11 ·
Did you find an answer to the stuck nav system?
Yes, for beginners I updated system, then updated maps, figuring that would reset the Nav. ?
After that, I let bike sit overnight hoping things would cycle itself out.
Opened up ride command in the morning but no luck,,still cycling in nav..(buffering?)
Anyways as its cycling I pushed the left handle bar button inwards that's next to volume control, and waa la!
Everything went back to normal and all functions working 100%.
Whew..so I went for a nice 2hr scoot, man this challenger is awesome..just WOW!..
 
1 - 11 of 11 Posts
Top