Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
439 Posts
Discussion Starter · #1 ·
Hey folks

Anyone come across the fusebox being loose in your Scout?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
332 Posts
What do you mean by loose? The fusebox is just one piece of plastic clicked into another along the frame rail, so you can definitely wiggle it around with your hands. Mine is a pain to get clicked back in if you take it out.
 

·
Registered
Joined
·
439 Posts
Discussion Starter · #3 · (Edited)
My mistake .. not the fusebox but connections from the battery. I had power at first when I cranked the engine and then nothing , no lights , no indicators .. I jiggled the lines and I then got power ..and everything is tight on positive and negative .. was wondering if others may have this issue


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
332 Posts
Yes. On mine the screws connecting the cables to the battery are on the short side. Like only 1 thread engages when you tighten them down, and you can't get it real tight without it feeling like it's going to strip.
 

·
Registered
Joined
·
456 Posts
Just installed longer screws when adding to the battery - that’ll prevent that
 
  • Like
Reactions: jjhemphill

·
Registered
Joined
·
456 Posts
Duct tape and a hammer fix everything :devilish:
 
  • Like
Reactions: jjhemphill
1 - 7 of 7 Posts
Top