Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JULY's Ride of the Month Challenge!
1 - 10 of 10 Posts

·
Rider
Joined
·
1,658 Posts
Discussion Starter · #1 ·
So after some serious reading via the search engine on this forum I decided to try something out. I called my dealership and spoke with one of the mechanics \ service techs. At least for the 2018 chief vintage no reflash is required to run a led bulb.

Like fellow members I found the stock halogen bulbs to be lacking. Since I'm trying to keep the vintage look I don't want to replace the headlight and fog light assembly with a modern space age looking light.

Thanks to others who spent the money on the Sylvania bulbs and had mixed results. Apparently on halogen bulbs the brighter they are allegedly the faster they burn out. So of to Amazon I went so I could read reviews. I ordered a bulb from Auxito its a direct replacement H4 9003 LED. Its a 6000 lumen 6500 K Xenon White.

This bulb is designed to be a direct replacement and has the same overall length as the OEM bulb. It has a integrated cooling fan and driver to avoid error codes and eliminate any radio interference. A pair on sale is $50.00 and free shipping. So I ordered a pair that should be here on May 7th.

For the fog lights I went with the same company and got a pair that are the same 6500 K light color and these are 1800 lumen a piece. They will be here on the 8th. So I'm looking forward to installing them and reporting.
 

·
Rider
Joined
·
1,658 Posts
Discussion Starter · #4 ·
Ok I got the lights in. What a SOB of a job by ones self. The freaking headlight cover is heavy. So got the lights in pretty impressed no error codes.Two things to note:
1. The headlight will not automatically come one when you hit the power on / off button but it will after you start the motorcycle
2. The power on / off button no longer is green after you press it but will turn red.

I’m not quite sure what to do since I’m not getting any error codes. Bike starts and runs fine.
 

·
Registered
Chieftain 2018
Joined
·
164 Posts
Ok I got the lights in. What a SOB of a job by ones self. The freaking headlight cover is heavy. So got the lights in pretty impressed no error codes.Two things to note:
1. The headlight will not automatically come one when you hit the power on / off button but it will after you start the motorcycle
2. The power on / off button no longer is green after you press it but will turn red.

I’m not quite sure what to do since I’m not getting any error codes. Bike starts and runs fine.
H8 is this item?



Inviato dal mio iPhone utilizzando Tapatalk
 

·
Rider
Joined
·
1,658 Posts
Discussion Starter · #6 · (Edited)
Yep and it’s a direct replacement they fit just fine. The main light is a H4 the dust boot is a little tight fitting on the back of the replacement H4 bulb. Th e headlight assembly is heavy FYI
 

·
Registered
Chieftain 2018
Joined
·
164 Posts
Yep and it’s a direct replacement they fit just fine. The main light is a H4 the dust boot is a little tight fitting on the back of the replacement H4 bulb. Th e headlight assembly is heavy FYI
Did you had errors message from control unit after this upgrade with led lights? The h4 replacement did not cause damage to the chrome of the headlight due to too much heat?


Inviato dal mio iPhone utilizzando Tapatalk
 

·
Rider
Joined
·
1,658 Posts
Discussion Starter · #8 · (Edited)
Nope, the H-8 LED has a integral fan That sits inside the main headlight housing and it’s actually cooler than the halogen. No issues with the fog lights either.
 

·
Registered
Joined
·
2,058 Posts
Ok I got the lights in. What a SOB of a job by ones self. The freaking headlight cover is heavy. So got the lights in pretty impressed no error codes.Two things to note:
1. The headlight will not automatically come one when you hit the power on / off button but it will after you start the motorcycle
2. The power on / off button no longer is green after you press it but will turn red.

I’m not quite sure what to do since I’m not getting any error codes. Bike starts and runs fine.
So the only issue is the button doesn’t turn green when the passing lamps are on. Is that correct?

If that is the case do they light up the road any better than stock?


Sent from my iPad using Tapatalk
 

·
Rider
Joined
·
1,658 Posts
Discussion Starter · #10 ·
No....after I installed the main headlight the power button won’t turn green. And yes way way much brighter than the stock halogen. The main headlight is 6,000 lumens by itself.
 
1 - 10 of 10 Posts
Top