Indian Motorcycle Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1,312 Posts
Discussion Starter #1
Friday morning in Texas was a bit cool and a bit windy but I needed a ride. I have been meaning to go to the Indian house because my tire pressure monitors were telling me nada. Got on the rode for a nice 50 - 60 mile drive to visit. Walked in and told them the issue. They have the unit near at hand. This didn't give me the warm and fuzzy feeling concerning them. I asked the wrench about how often they have to reset these things. He said not that often as long as no one is messing with any of the wiring under the seat. I stated that I have not pulled the seat at all so something else is going on. I was told he didn't know. They were reset and I took the bike on a 150 mile ride. Everything worked well. I will be keeping an eye on them and if they reset themselves again, I will have a ticket drawn up.

Hoped to have the time to knock out the plugs from my factory pipes but, as always, the weekend got away from me. So that will have to wait for another day. I did ask the wrench if they would do a stage 1 flash if I knocked out the plugs...and was told $48 and they will do the flash.

Semper Fi,
DrZ
 
  • Like
Reactions: CavemanHHH

·
Premium Member
Joined
·
3,571 Posts
A bit cool is relative to where you live. Took mine out for a ride to divide then into the town of Woodland Park. 21 miles to go 4, bought items for dinner, the back home. Got to get those miles in before I get snowed in at 9000 ft, then I am stuck with the 4x4. It may void my warranty by putting chains on my bike.
 
1 - 2 of 2 Posts
Top