Indian Motorcycle Forum banner
1 - 1 of 1 Posts

·
Bronze member
Joined
·
1,593 Posts
Discussion Starter · #1 ·
Just replaced my Indian stock headlight bulb with a Rivco LED bulb (driving lights too). The instructions said to remove the stock rubber boot around the original bulb and set aside, as it will not be needed. It also came with a spring that it said “might be needed“ on some models. (Love that!) I didn’t see any way or need to use the spring, and the wire clasp that holds the stock bulb in place (with the boot) is properly connected on both ends and seems to be doing its job. I noticed though that there is a little bit of play in the bulb — I can put a finger on it and with a little pressure, move it side to side or up and down just a bit. But it seems secure, and I know I got the adapter ring properly secured on the adapter ring, and the three tabs on it are properly seated in their slots in the housing. Hope that makes sense.... So I’m wondering if anyone knows if this play is normal. The bulb seems to be secure enough. Any thoughts?

For the record, the driving lights were super easy to replace and definitely ARE “plug-and-play.” The headlight bulb was a bit of a beyotch to get in because I was working from behind and didn’t mess with any nacelle removal or anything like that — so there was definitely limited space back there to work with. Generic instructions like what came with it are sometimes a challenge to work with. But I think we’re all good....
 
1 - 1 of 1 Posts
Top