Indian Motorcycle Forum banner

1 - 13 of 13 Posts
J

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Have #464 new indian chieftain not even 500 miles on it already had to be trailered to the indian dealer. Bike was completly dead. They pulled out a breaker and put it back in and bike started right up. Dealer said there is no fix polaris said it should not do it again. Dealer at least showed me what to do just in case polaris is wrong. Had to hit the breaks hard and the back tire did skid ABS does not seem to be working. Let my Dad ride it he crosses an intersection and bike dies. Dash is dead no lights on headlight or anything. Hit the power button and bike lights back up and starts right up. Rode it 86 miles no problems after that. I realize it is 1st production year bike but I have had 6 victories still own a 2012 cross country tour (best bike still made) traded a 2013 Hardball for the indian chieftain. Never had major issues like this with my victories. My hard bags under side are not painted as well on the Indian. Dealer tells me new ones are on the way. Sent an email to Polaris but I am told although they do not sell bikes in the volume HD does there customer service sucks just as bad as HD. They seem to be right was told in 3 days I would get a response its been a week got nothing from them. I am hoping I do not regret buying this. The bike is a blast to ride when it works. If some one else is having similair issues please let me know.

UPDATE

I stand corrected on one thing Polaris did call me Friday the voice mail for what ever reason did not show up on my phone until later I also recieved an email from them today monday. They have a case # started for me and they seemed as if they where wanting to know more about the issues. This does make me very happy and I feel like they at least care. Whitch is great cause this bike has so much low end torque and its so fun to ride. I really just want the issues worked out. So maybe they do have better customer support then HD!! :) None the less I hope they read the vog and make improvments from it.

Once I talk to them I will post the out come of the conversation.

10/22/13

Had my conversation wth Indian was very impressed with there customer service. They took note to the issues i was having.

1. Assured me replacment bags where on the way.
2. Reasearching why the bike will go dead and pulling the breaker not fuse fixes the bike. Not the first to have this issue.
3.Unfortinitly they were not aware of it dying will riding but thanks to the VOG that they did say they read every once in awhile to check on customer satisfaction and Other blogs/post websites I was not the only one that expieranced this. He hoped it is just a software update. But as for now need more customers to expeirance the problem and report them to be a priority to fix. Hard to fix when it is not happening at the dealership.

So probibly all that can be expected hope not to have any of these issues agian. if they do come back hope Indian has a fix for it.

Glad for a 5 year warrent and 24/7 800 # to call

Did not mean to be a troll or what ever that is but wanted a place other indian riders that experince the same issue can at least see they where not the only ones. It is a little comferting to see others having the same issue as some one smarter then me will usaully find a fix.

Thanks and thanks Polaris for the customer service from both the dealer and Indian.
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #2
I bought the first production year XR (2010) and have been EXTREAMLY happy. No major complaints. I've heard about all the problems people test riding at Sturgis had and then the big delay in shipping the bikes. To me, it seem like Polaris felt pressure to release the bike at Sturgis. I think they knew there were some glitches but thought they could address them between the release and when the new bikes would be shipped. I think they underestimated how hard it is to fix electrical glitches, ESPECIALLY software glitches.

Had they separated the release from the self imposed need to be at Sturgis I think they would've been better off. After all, you never get a second chance to make a first impression.
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I feel your pain. I had issues with my chief with less than 500 miles. Same thing on brakes. Dealer said they needed adjustment, rear one still locks up after dealer adjustment, CHK ENG on dash but no code. Dealer says nothing to worry about, this is aggravating to see, also a nick in shield, dealer took picture and is waiting on response from INDIAN. I do not feel there is anything to discuss about shield it should have been replaced before pick up but I had traveled 170 miles and was not told about the nick till I got to dealer. I now have 970 miles on bike and it seems good CHK ENG reset by dealer at 500 mile check up, it was back in before 1 gas fill up. Oh and 500 mile cost me 350.00. I am just saying that's a lot for an oil change.
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Did they offer you a happy ending along with that oil change for $350? Holy smokes!!!
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #7
18798 said:
The OP has edited his original posting, and has changed his tune a bit.
I can understand his original unease with Polaris/Indian.
He seems to be in a better frame of mind now.

 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #9
4360 said:
Go back and reread the first post.
It has been edited.

Everyone has a first post.

I re-read it.
Now let's hope the OP gets his bike sorted out.

You only have one chance to make a first impression.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #10
Polaris should hire the software people who did the Affordable Healthcare Website to fix the problems.
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #11
14423 said:
Polaris should hire the software people who did the Affordable Healthcare Website to fix the problems.
They already have them working on their online parts catalog.
 
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #12
14423 said:
Polaris should hire the software people who did the Affordable Healthcare Website to fix the problems.
You mean the company the tax payers shelled out 634.5 million bucks to and now the site is not working correctly so we the taxpayer will be shelling out more money?
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #13
2108 said:
You mean the company the tax payers shelled out 634.5 million bucks to and now the site is not working correctly so we the taxpayer will be shelling out more money?
He means the same company that the Canadian healthcare services fired! Oh! Wait a minute, those ARE the same ones currently running the US's website... nevermind!
 
1 - 13 of 13 Posts
Top