Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
As almost everyone does, since I've gotten my bike (2015 Indian Chief Vintage) I've made several updates and improvements. Freedom Performance True Duals, Wimmer high flow air cleaner, Power Commander 5 (PCV), and, most recently, 60mm throttle body. After putting on the new throttle body my idle RPM's have significantly increased; going from the original 700 - 750 RPM's at Idle to 1100 - 1200 RPM's at normal operating temperature. I'm assuming this is a result of getting more air into the cylinder.

Has anyone else had this issue? Is there a way to re-adjust it back to normal Idle RPM's? As far as I know, there is no way to use the PCV to adjust the RPM. Since I am using the PCV, I never did the Stage 1 re-flash of the ECM. Will that help? Any help from someone who's handled this would be greatly appreciated.
 

·
Bronze member
Joined
·
1,294 Posts
As almost everyone does, since I've gotten my bike (2015 Indian Chief Vintage) I've made several updates and improvements. Freedom Performance True Duals, Wimmer high flow air cleaner, Power Commander 5 (PCV), and, most recently, 60mm throttle body. After putting on the new throttle body my idle RPM's have significantly increased; going from the original 700 - 750 RPM's at Idle to 1100 - 1200 RPM's at normal operating temperature. I'm assuming this is a result of getting more air into the cylinder.

Has anyone else had this issue? Is there a way to re-adjust it back to normal Idle RPM's? As far as I know, there is no way to use the PCV to adjust the RPM. Since I am using the PCV, I never did the Stage 1 re-flash of the ECM. Will that help? Any help from someone who's handled this would be greatly appreciated.
Get a PVCX and get a flash from fuelmoto they can help.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #3 ·
I have a strange update. So, on Monday I decide to plug in the Power Commander Software program just to see what map is saved in there and to see if maybe I could recalibrate the throttle position. Basically just trying to tell if there was anything I could do to help the situation. So I plug the cable in, the PCV power light lights up and the status light flashes a few times but the software shows "No Device Connected". I tried a different USB cable and same thing. I put the bike back together and decided to deal with it later.

Fast forward to Tuesday I decide to go for a little ride and about 10 miles in (at a stop light) I realize that the RPM is back down to the 750 range like it should be. I guess plugging in the PCV (even though it didn't connect to the software) was enough to awaken it to start working right. This isn't the first time that I've had trouble with the PCV either. I know several of you are using something other than Power Commander. What other devices do you all like to use?
 

·
Bronze member
Joined
·
1,294 Posts
PVCX get through FuelMoto.
 
1 - 4 of 4 Posts
Top