Indian Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I Have some problems with my speedometer lights.
Last thursday catch heavy rain with the bike.
So Friday night went for a run, and my speedometer lights where out, only the needle (pointer) was red.
yesterday started the bike at night and all the lights where On.
After 20 Km, the lights where out again.
When i was going home, in movement the lights turns back On.
Anyone had this issue?
Bad wiring contact?
The heavy rain hit some connections?
Regards
 

·
Bronze member
Joined
·
3,734 Posts
The only wiring you can check is the connector under the speedo. It's an easy job to remove the console, only two screws front and rear. You could check to see if there is any moisture under there, but it should be well sealed.

You might have water inside the speedo unit, but once again that should be fully sealed. You can also check this by parking the bike out in the sun and watching to see if any moisture condenses under the speedo glass.

I'd also do some night riding and if it fails again, take some photos of it when the lights are out to take to the service guy. It should be a warranty replacement if there is an obvious problem but the service guy won't be able to see any problem in the daytime.
 

·
Silver member
Joined
·
4,419 Posts
Is there condensation under the glass?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
yes, i stay with some condensation after the heavy rain. After 3 days at Sun it is gone. But the lights also gone...
 

·
Registered
Joined
·
54 Posts
Hmmmmm ... I kinda like that better !
Darn thing is sooo hard to read at night but with JUST the Needle Glowing you can tell how fast your going !
I may disable the lights ! LOL
 

·
Registered
Joined
·
21 Posts
Discussion Starter #8
lol, i also like it like this, only with the needle glowing, but without other light you don't see any information on the odometer... only the warning lights are ON
 
1 - 9 of 9 Posts
Top