Indian Motorcycle Forum banner

Hot rodded Chieftain116 throwing codes.......

1414 Views 2 Replies 3 Participants Last post by  Baron58
So I purchased a very massaged 2018 Chieftain Elite. I bought it 6 weeks ago with 1400 miles on it, and it currently has about 2400 miles.
Mods are:
-Indian 116ci Kit
-Lloyds 585 cams
-Carillo Rods
-DynoJet Power Vision Tuner
-FuelMoto Tune
-Rinehart Slimline Headers
-DNA Megaphone Exhaust w/2.5” baffles
-S&S Air Cleaner

While riding Saturday I hit the throttle and it basically went into limp mode. Engine light came on. I pulled off the road, shut down, and restarted, bike started right up and rode home ok. I connected the Dynojet tuner and the Historic codes showing were:
524080-31: Cruise Control Input Message Counter- Counter not incremented
523-3: Gear sensor signal- voltage too high.
520305/31: Throttle Body Control - requested throttle angle not plausible- Condition Exists

I've been planning on getting the bike dyno'ed and tuned because it does pop a bit when starting and has stalled a few times at lights. Original owner never had it tuned. Otherwise it seems to run great. Am I looking at a huge issue with the throttle body? I cleared the code with the tuner and it did stay off.
1 - 3 of 3 Posts

· Bronze member
Joined
·
6,270 Posts
So I purchased a very massaged 2018 Chieftain Elite. I bought it 6 weeks ago with 1400 miles on it, and it currently has about 2400 miles.
Mods are:
-Indian 116ci Kit
-Lloyds 585 cams
-Carillo Rods
-DynoJet Power Vision Tuner
-FuelMoto Tune
-Rinehart Slimline Headers
-DNA Megaphone Exhaust w/2.5” baffles
-S&S Air Cleaner

While riding Saturday I hit the throttle and it basically went into limp mode. Engine light came on. I pulled off the road, shut down, and restarted, bike started right up and rode home ok. I connected the Dynojet tuner and the Historic codes showing were:
524080-31: Cruise Control Input Message Counter- Counter not incremented
523-3: Gear sensor signal- voltage too high.
520305/31: Throttle Body Control - requested throttle angle not plausible- Condition Exists

I've been planning on getting the bike dyno'ed and tuned because it does pop a bit when starting and has stalled a few times at lights. Original owner never had it tuned. Otherwise it seems to run great. Am I looking at a huge issue with the throttle body? I cleared the code with the tuner and it did stay off.
The requester throttle body control is triggered when you request a throttle position greater than the ECU can do I.e. rapid throttle movement. The drive by wire tables can be adjusted to minimize this error. As for the others not quite sure.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top