Indian Motorcycle Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1
So I switched to high beam and the light went to high beam with my blue indicator light flashing. When I switched to low beam, the light stays on high beam and the blue indicator stays flashing. When I restart the bike with low beam on, no issues until I switch to high beam. Error code 0. SPN 2348 and FMI 5. ( I pulled those codes from my MFD).
Which means.....high beam lamp and short to B+.

Anyone else have this?

I am thinking of checking all the electrical connections and spraying them with contact cleaner.
 

·
Bronze member
Joined
·
5,078 Posts
The same question is on another thread over the last few days. Maybe there's a virus ...
The flashing indicator means the bulb has blown.
 

·
Rider
Joined
·
620 Posts
Just replace the bulb with an LED set or something from Eagle. Really isn't that expensive and hell of a lot better. The bulbs are such a pain in the god damn ass to change.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #7
Yep, a simple fix with a common H4 55/60 watt bulb. And further investigation lead to the high beam being burned out. Took close to an hour to change getting the spot lamps, nacelle and windshield bag off and on.
 

·
Bronze member
Joined
·
2,978 Posts
2348 is the code for a burned out low beam and 2350 is the code for a burned out high beam.I've gone thru four bulbs over the last 2 1/2 years and 39000 miles traveled.And the reason I believe these bulbs burned out was because the frame rail battery ground connection was not tight enough which I have since, corrected.So that's something ya might wanna check!!
 
1 - 10 of 10 Posts
Top