Indian Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
165 Posts
Discussion Starter #1 (Edited)
Odd behavior from "Running Bear," my 2015 Indian Chief Classic. When I try to start it now, to no avail, the hazards start blinking.

Context:
  1. Michigan temps went from single digits Fahrenheit to 50 degrees today (that's the good news).
  2. When I opened the garage door my bike was covered in condensation from the temperature change (bad news).
  3. I decided to take him off the trickle charger showing a full charge and start him up.
  4. It took quite a few attempts, but he started and I let him run for 15 minutes w/ a big fan pointed at him from the front.
  5. After he was warmed-up I put the kickstand up and tried running through the gears while stationary.
  6. When I clicked up into 3rd gear the horn started sounding.
  7. I tried to click it back down into Neutral and noticed the hazard lights were on.
  8. I hit the Kill Switch and tried to put it in Neutral. It went in neutral but the "N" light wasn't appearing.
  9. The hazard lights kept blinking even though it wasn't in gear and the bike was off.
  10. After 30 minutes I put it in 1st then back to Neutral and the "N" light turned on. The hazard lights turned off.
After all of this drama, now he won't start. He won't even turn over. I reconnected the trickle charger and now it's only showing 2 of 5 lights. Odd.

I plan on digging into the Owner's Manual tomorrow to do some sleuthing but wondered if anyone in these forums has experienced something similar.

Does this mean his battery is toast? It seemed as right as rain and strong when I put him away in mid-December.

Thanks, and cheers!
 

·
Bronze member
Joined
·
1,825 Posts
Did you turn the kill switch back on? Sometimes, it is a forgotten thing in all the confusion of flashing lights and beeping horns.

On a side note, your bike has its own song.
 

·
Registered
Joined
·
165 Posts
Discussion Starter #3
Did you turn the kill switch back on?
Yessir. I did.

P.S., Cool song title, but not a very cool song! I can't believe the great Randy Bachman allowed that song to be recorded. "American Woman" was much better. LOL
 
1 - 5 of 5 Posts
Top