Indian Motorcycle Forum banner

Gear switch/sensor issue

10922 Views 16 Replies 10 Participants Last post by  thehueypilot
I have a 2014 Indian chief vintage with 35000 miles.

A couple of days ago, my bike started experiencing an intermittent problem, which usually happens after the bike has been ridden and warmed up for a while (sometimes the problem exists, other times it does not).

Specifically, when I start the bike in neutral with the kickstand down, the bike turns over, the RPMs go up to their characteristic 1300, and as the RPMs settle down to the warmed up idle speed (700-800 rpm), the neutral gear position quickly changes to first gear, and then back to neutral.

The problem is that when the bike momentarily thinks it's in first gear, the bike stalls because the kickstand is down. I'm able to navigate around this problem by either starting the bike in first gear or starting the bike in neutral with the clutch pulled in.

The display will also switch from neutral to First and back to neutral when the kickstand is up, but it wont stall. Sometimes it will just stay in the false first, before I kick it into real first.

I'm presuming there's an electrical issue or a problem with a sensor which is causing the bike to misidentify itself for a brief moment in first gear. The only error code that the bike displays is the kickstand being in the down position while I'm first gear

The link is a video of the problem. In this video, the kickstand is down. And if you look at the gear reading on the LCD display, you will see it quickly switch from neutral to First, and back to neutral causing the bike to stall.

https://goo.gl/photos/tg82jFXwrXjaKsN28

Someone please help
1 - 1 of 1 Posts
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top