Indian Motorcycle Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 · (Edited)
I have a 2014 Indian chief vintage with 35000 miles.

A couple of days ago, my bike started experiencing an intermittent problem, which usually happens after the bike has been ridden and warmed up for a while (sometimes the problem exists, other times it does not).

Specifically, when I start the bike in neutral with the kickstand down, the bike turns over, the RPMs go up to their characteristic 1300, and as the RPMs settle down to the warmed up idle speed (700-800 rpm), the neutral gear position quickly changes to first gear, and then back to neutral.

The problem is that when the bike momentarily thinks it's in first gear, the bike stalls because the kickstand is down. I'm able to navigate around this problem by either starting the bike in first gear or starting the bike in neutral with the clutch pulled in.

The display will also switch from neutral to First and back to neutral when the kickstand is up, but it wont stall. Sometimes it will just stay in the false first, before I kick it into real first.

I'm presuming there's an electrical issue or a problem with a sensor which is causing the bike to misidentify itself for a brief moment in first gear. The only error code that the bike displays is the kickstand being in the down position while I'm first gear

The link is a video of the problem. In this video, the kickstand is down. And if you look at the gear reading on the LCD display, you will see it quickly switch from neutral to First, and back to neutral causing the bike to stall.

https://goo.gl/photos/tg82jFXwrXjaKsN28

Someone please help
 

·
Registered
Joined
·
494 Posts
If you search you'll find a write up on this. Replaced under warranty at the dealer. rare, but a few have had this problem.
 

·
Registered
Joined
·
494 Posts
I had the gear indicator switch replaced under warranty. It did not fix the problem
Ah! There is nothing else in the sequence--I think--that would cause this problem other than the gear sensor. Maybe it's a problem with the ECU firmware load? That's what senses the resistance fro the gear sensor to decide that to put on the display. Reflash the ECU? Just a thought for the Dealer.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Ah! There is nothing else in the sequence--I think--that would cause this problem other than the gear sensor. Maybe it's a problem with the ECU firmware load? That's what senses the resistance fro the gear sensor to decide that to put on the display. Reflash the ECU? Just a thought for the Dealer.
Good idea. I'll run it past the mechanic.
 

·
Rider
Joined
·
1,069 Posts
Last night my 2014 Chieftain with 28000 miles tried to do me in. After getting gas I started the bike up since the dash showed the bike was in neutral. I usually pull in the clutch when I start a bike but this time I did not and to my amazement the bike lurched forward because the mf'er was in first gear. I hit the kill switch and luckily I did not dump the bike or hit anything. I then shifted up one time and the bike said I was in second gear. I pulled the clutch in started the bike and then slowly let the clutch out. Well the bike was in neutral but showing 2nd gear on the dash and the engine did not die when I put the side stand down. I just called Arlen Ness service department and spoke to a service rep to see if there have been other bikes with this issue. He puts me on hold, speaks to the mechanic. Comes back on and says the problem might be a fried clutch ( doubt that since I don't do burnouts) or bent shift linkage from me shifting too hard. Neither of these response seem right and to me it seems they are trying to blame me for this issue. I shot a video of the bike sitting there in second gear idling with 2nd gear showing on the dash. I called Arlen Ness to see if they might think the ECM is starting to act up or if they have seen this issue with other bikes. Don't like how they are trying to put the blame on me and not the bike. You can see that I'm holding the iPhone with my left hand and my right hand is also in the reflected image on the dashboard.

 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Hamador1

The solution to your problem is probably quite simple. It sounds like a problem with the gear switch sensor. It's a quick swap. If it hasn't already been discussed above, the way that your LCD screen determines what gear your in is determined by how many ohms are coming through the sensor. The sensor is likely faulty
 

·
Rider
Joined
·
1,069 Posts
Hamador1

The solution to your problem is probably quite simple. It sounds like a problem with the gear switch sensor. It's a quick swap. If it hasn't already been discussed above, the way that your LCD screen determines what gear your in is determined by how many ohms are coming through the sensor. The sensor is likely faulty
Agree and I spoke to my BMW bike mechanic who has over 40 years of wrenching on bikes. He said the guy at Arlen Ness was full of shit and said it's the gear position sensor going bad.
 
  • Like
Reactions: Roadie

·
Registered
Joined
·
1 Posts
I had the gear selector switch replaced twice. Once for warranty and once because the part failed again. Apparently they put the same switch back in as what was on the recall. Seems dumb. When it failed the second time I had to make them test the switch with a multi meter to prove it was bad. They told me they replaced it with a "redesigned " part. Guess what, I've ridden twice and its failed again. What do I do? Call Polaris? The dealer gets bucky about it and the next nearest dealership is over an hour away.
 

·
Registered
Joined
·
12 Posts
That's why I haven't had my switch replaced under the recall, it's working fine and it seems that almost everyone who had it done ends up with problems, some people are on there 2nd and 3rd switches and when they flashed the ECU's other problems came up like the low tire light flashing, things dont work right malfunction lights are on , vehicle lighting issues etc etc etc, dealers try to sell stuff to fix the bikes and say it's not the recall that caused it and sorry your bike is out of warranty, yes no lies this is happening
 

·
Registered
Joined
·
4 Posts
I had the gear indicator recall done in June of 2020 on my 2016 Chieftain. June of this year if started acting up again. Dealer acknowledged having to do it two or three time on other bikes and then stated they (the dealership) had to "eat the cost". They tried to charge me to get it fixed again. I bitched and they decided not to charge me.
 

·
Registered
Joined
·
449 Posts
More information about this common issue.

Tim
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top