Indian Motorcycle Forum banner

1 - 20 of 75 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter #1
I received the recall notice in mid April. I called the local dealership to schedule an appointment, but was told that they didn't have the part and took my name to notify me when the part came in. After not hearing from them for about 6 weeks, I called again in June and they said there were still people ahead of me waiting to get the recall service done. I still have not heard from them yet about bringing my bike in for the service.

I have read a couple of other threads that indicated that Indian had problems with the initial fix and were doing a recall of the recall. I am wondering if there are still issues with the fix and that is the reason I have not heard from my dealer. Or is the problem with the dealer? I bought the bike from them and have had pretty good service from them so far, but it has been 3 months since I first contacted them.
 

·
Bronze member
Joined
·
2,985 Posts
Mine was scheduled to be done this AM.However,since black clouds were present,and heavy rain was rapidly approaching,I called and canceled,rescheduling it for tomorrow morning.Why?? Cause it's a 30 mile ride one way to the shop.So maybe,just MAYBE,I'll "FINALLY" get er done TOMORROW "IF" it doesn't frigin rain,AGAIN!! DUH!!!
 

·
Registered
Joined
·
176 Posts
Got mine replaced 5/9. The dealer experience was good, scheduling, etc. but I never had a problem with the original part - and since the "fix" was done, it seems as though the display is slower at indicating the gear. Granted, I usually know what gear I'm in anyway, but the display didn't read "--" nearly as much before the service. FYI.
 

·
Registered
Joined
·
737 Posts
Got mine replaced 5/9. The dealer experience was good, scheduling, etc. but I never had a problem with the original part - and since the "fix" was done, it seems as though the display is slower at indicating the gear. Granted, I usually know what gear I'm in anyway, but the display didn't read "--" nearly as much before the service. FYI.
My 2014 did not have any issues with the sensor either. Smooth and positive experience at my dealership. I have not noticed the slower position indication.
 

·
Registered
Joined
·
161 Posts
Discussion Starter #5
I HAVE had some issues with the gear position indicator on my 2017 Springfield. Occasionally, it will lag behind in indicating the correct gear showing I'm in 2nd when should be 3rd, 3rd when it should be 4th. After 10-15 seconds it will correct to show the right gear. When this happens, the check engine light will come on and stay on thru several engine start/stop cycles and then goes away. Not really a big deal, but i would like to get it fixed since Indian is doing it as a recall.
 

·
Bronze member
Joined
·
3,940 Posts
I HAVE had some issues with the gear position indicator on my 2017 Springfield. Occasionally, it will lag behind in indicating the correct gear showing I'm in 2nd when should be 3rd, 3rd when it should be 4th. After 10-15 seconds it will correct to show the right gear. When this happens, the check engine light will come on and stay on thru several engine start/stop cycles and then goes away. Not really a big deal, but i would like to get it fixed since Indian is doing it as a recall.

Beside the bike possibly being in gear when it says neutral (which pulling the clutch is good safety measure) The other issue is cruise control will not work unless your in 4th gear or higher. That in itself is another good reason to get the switch replaced.
 

·
Registered
Joined
·
557 Posts
Got mine replaced 5/9. The dealer experience was good, scheduling, etc. but I never had a problem with the original part - and since the "fix" was done, it seems as though the display is slower at indicating the gear. Granted, I usually know what gear I'm in anyway, but the display didn't read "--" nearly as much before the service. FYI.
You may need to get reflashed again.
There was a problem with N delay during the first cpl weeks of the recall being out.

Sent from my SM-G965U using Tapatalk
 

·
Bronze member
Joined
·
3,096 Posts
Can you just get the new part?or do you have to let them put it in?
I just as soon get the part or pass on that recall.
 

·
Bronze member
Joined
·
2,985 Posts
You could,and do it yourself .[it's pretty straight forward to do] But it will need to be reflashed too,meaning you'll need to get into their Digital Wrench system ,[good luck with that,lol] otherwise,the ECM / VCM won''t recognize the new component and you'll have balls starting it,amongst other things,atleast according to what the SM at the place I bought mine from,was telling me in a conversation we had about it.Dave!!!
 

·
Bronze member
Joined
·
5,082 Posts
I have read a couple of other threads that indicated that Indian had problems with the initial fix and were doing a recall of the recall. I am wondering if there are still issues with the fix and that is the reason I have not heard from my dealer. Or is the problem with the dealer? I bought the bike from them and have had pretty good service from them so far, but it has been 3 months since I first contacted them.
For a while there was talk of a second recall but it turned out that Indian was sending duplicate letters to people. I think the dealers were struggling with the number of bikes to do and the work was lagging behind the expectations of head office. One or two members said their dealer was only doing a few each week as it was interfering with their regular workflow.

There have been a few members on here who say their new sensor was not working properly and was replaced a second time. And there are a few who say they had to get the VCM reflash done a second time. The new sensor has the internal resistors for 1st and 6th swapped around and if the reflash is not done the bike will show 6th when it's in 1st and show 1st when it's in 6th, preventing cruise control in top gear.
 

·
Bronze member
Joined
·
2,985 Posts
Well gang,just came back from having my gear position switch changed.It took alittle over an hour to do and I watched the whole operation,asking questions as the guy went along.After the switch was completed,they down loaded some new sotfware or whatever it is they do,and off I went.I got about 5 miles down the road,and the motor stumbled,came back,stumbled again,then returned to normal and all was OK after that.But I also lost my TPMS.So,needless to say,as soon as I got home,I called the dealer back to tell em, and they said apparently the new down load didn't take all the way,so they will do it again tomorrow or the next day. [it's supposed to rain tomorrow!! AGAIN!!!].But over all with this new software,she did run even better then before,with the exception of that stumbling problem I had.So,hopefully,they'll kill two birds with one stone when they do it again.I'll keep ya all posted.Dave!!!
 

·
Rider
Joined
·
1,057 Posts
Mine is working ok on my 2019.
So It isnt worth the hassle to just follow the recall and get it done and they cock it up.
Flash didnt quite take all the way?? It either did or didnt. Bad replacement switches bad too.
What a bunch of crap. Things being even worse then when you went in.
 

·
Registered
Joined
·
82 Posts
When doing the recall I have found bikes with stage 2 in them are a problem after the reflash.There is a throttle adaptation that needs to be done.Reflash the bike and wait 30 seconds before shutting bike off or touching the digital wrench.After the 30 seconds you shut off the bike only and wait 130 seconds before touching anything else.This helps with running issues. This is not in any manual and came straight from a Polaris/Indian tech at the mothership.
Hope this helps some of you with running issues
 

·
Bronze member
Joined
·
5,082 Posts
t.But I also lost my TPMS.So,needless to say,as soon as I got home,I called the dealer back to tell em, and they said apparently the new down load didn't take all the way,so they will do it again tomorrow or the next day. [it's supposed to rain tomorrow!! AGAIN!!!].But over all with this new software,she did run even better then before,with the exception of that stumbling problem I had.So,hopefully,they'll kill two birds with one stone when they do it again.I'll keep ya all posted.Dave!!!
I don't know what bike you have but on the Springfields the TPMS moves from the left toggle switch to the right. And the VCM forgets the sensors and has to re-learn them. It also changes the PSI ability to KPA only. Nobody can tell me how to get it to do PSI again. My head doesn't do numbers because of dyslexia and the move from the familiar 36 psi to 200-300 of the other is a headache.

The stumbling sounds like they flashed a new tune to the ECM. That's the only time my bike has behaved like that. It stumbled a few minutes out of the shop and settled down within a few minutes of bad running.
 

·
Bronze member
Joined
·
2,985 Posts
Thank you sir for that info as it appears that's EXACTLY what happened regarding the TPMS.I just went out to my shop and tried it ,and BINGO,that's exactly what happened.Before the update,on my SDH,the right toggle switch did nothing.But now,it does, in fact, show the TPMS readings.So THANK YOU sir for that info!!(y)(y)(y)(y)(y) Dave!!!
 

·
Bronze member
Joined
·
2,985 Posts
Mine was alittle over the 39,000 mile mark when it was done yesterday.Point being:after you've logged some mileage on,THEN,it may or may not start acting up.Mine was,but is now "PERFECT" with that new switch and the down load that went with it!!
 

·
Bronze member
Joined
·
5,082 Posts
Thank you sir for that info as it appears that's EXACTLY what happened regarding the TPMS.I just went out to my shop and tried it ,and BINGO,that's exactly what happened.Before the update,on my SDH,the right toggle switch did nothing.But now,it does, in fact, show the TPMS readings.So THANK YOU sir for that info!!(y)(y)(y)(y)(y) Dave!!!
You're welcome. Does yours show PSI or only KPA?

The move to the right toggle has been a nuisance to some members on here who had re-purposed the switch for their garage door remote. Somewhere in a secret office there's a computer guy thinking, 'What can I surprise people with next?'
 
1 - 20 of 75 Posts
Top