Indian Motorcycle Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Went to pass someone on freeway. When I hit it, it misfired at 60 mph. It ran good afterwards but engine light was blinking. When I had the opportunity, I shut it off and turned it back on the engine light went off. This is the second time this has happen.
Warranty rod replacement on 116 was done over the winter and I had Vance and Hines slip-ons installed.
It was dyno tuned last year when I had the 116 initially installed with true duals and stock slip-ons. Should I get it re-tuned of is it something else?
 

Attachments

·
Registered
Joined
·
5,832 Posts
If it continues, should have thorough diagnostics done. However, a cylinder misfire may just be a random ocurrence that will elude explanation. You didn't mention what technology your tuner used nor how many miles on bike. History is important to consider when doing diagnostics on these bikes. It can be simple things like plugs, plug wires, coils, connections, sensors. Or it can be more involved with the ECM and it's communications.
 

·
Registered
Joined
·
5,832 Posts
If you are using Dynojet hardware and have the PVCX or PV3 you can log some runs and analyze from there. You will be able to see mixture anomalies and any major error conditions. You can ask FM or CraigB for some help with that. Normally a retune can be pretty straight forward since you will not be starting from scratch with everything.
 
1 - 3 of 3 Posts
Top