Indian Motorcycle Forum banner

Electronic issues, multiple

880 Views 9 Replies 6 Participants Last post by  Chief Signguru
2017 Springfield. Multiple electronic issues since purchase. Would not start after sitting for a week. In the shop for months before the gear position indicator re-flash was performed. It then worked fine for about a year. Then the Check Engine light came on and off intermittently. Sometimes it showed an error code of gear position indicator inaccuracy. Sometimes no code. Replaced battery and alternator and it was fine again for almost a year. Then the light came on and off again intermittently with the same code, or no code, or once with kick stand error code. It has cut out with all the lights but then did restart after about 5 minutes. Recently it would not start, all the lights were lit, no code. Waited an hour and it started. Riding down the road at about 30mph and the gear indicator went screwy in that it showed I was in neutral and the N light was also lit, but I was still in gear and had pick up. I have stopped reading the gear indicator because it is all over the place. A few times all the lights came on, while traveling, but there was no affect on operation. They stay on for a short while traveling, then go out. Recently all the lights came on but it would not start. It wouldn't turn over - nothing. I waited an hour, doing nothing, and then it started - but the check engine light stayed on. Again all the lights came on and it would not start. I happened to be at the dealer - the diagnostic computer would not recognize the bike. They have re-flashed multiple times. I'm just about at the end of my rope with this bike.
1 - 1 of 1 Posts
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top