Indian Motorcycle Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
2017 Springfield. Multiple electronic issues since purchase. Would not start after sitting for a week. In the shop for months before the gear position indicator re-flash was performed. It then worked fine for about a year. Then the Check Engine light came on and off intermittently. Sometimes it showed an error code of gear position indicator inaccuracy. Sometimes no code. Replaced battery and alternator and it was fine again for almost a year. Then the light came on and off again intermittently with the same code, or no code, or once with kick stand error code. It has cut out with all the lights but then did restart after about 5 minutes. Recently it would not start, all the lights were lit, no code. Waited an hour and it started. Riding down the road at about 30mph and the gear indicator went screwy in that it showed I was in neutral and the N light was also lit, but I was still in gear and had pick up. I have stopped reading the gear indicator because it is all over the place. A few times all the lights came on, while traveling, but there was no affect on operation. They stay on for a short while traveling, then go out. Recently all the lights came on but it would not start. It wouldn't turn over - nothing. I waited an hour, doing nothing, and then it started - but the check engine light stayed on. Again all the lights came on and it would not start. I happened to be at the dealer - the diagnostic computer would not recognize the bike. They have re-flashed multiple times. I'm just about at the end of my rope with this bike.
 

·
Bronze member
Joined
·
3,742 Posts
There was no "flash" for the Gear position sensor until March of this year when the recall came out to replace all Gear Position sensors and re-flash the VCM. Looks like you need to have the gear position sensor recall performed. Last fall a recall came out on a temporary cleaning fix for the gear position sensor until a replacement sensor was available in March 2020 of this year. All 111/16 bikes from 2014 -2020 are effected.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
There was no "flash" for the Gear position sensor until March of this year when the recall came out to replace all Gear Position sensors and re-flash the VCM. Looks like you need to have the gear position sensor recall performed. Last fall a recall came out on a temporary cleaning fix for the gear position sensor until a replacement sensor was available in March 2020 of this year. All 111/16 bikes from 2014 -2020 are effected.
Flash I-20-30 was performed. I'm not sure what it does. I believe they cleaned the original sensor but did not replace. Separately, it does not register on their diagnostic computer.
 

·
Rider
Joined
·
497 Posts
Yeah, it sounds like the gear position sensor is the least of your worries. Good luck
 

·
Bronze member
Joined
·
2,919 Posts
Could be a bad ECM,a bad PCM,or,the wiring in the harness could be incorrect from the factory.I say that cause I've seen those problems in brand new cars and trucks.No one is perfect,especially when it's put together on an assembly line.At any rate your machine should have been flagged right after ya got it.
 
1 - 10 of 10 Posts
Top