Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter · #1 ·
Not always but on occasion this code comes on when I start the bike. The engine check light does not come on. According to the diagnostic codes, it has something to do with vehicle speed not being detected accurately. It will probably be quite a while til I can get the bike to the dealership but my guess is that it's not something to be overly concerned about. This happen to anybody else?
 

Attachments

·
Founding member / Distinguished
Joined
·
2,354 Posts
Not always but on occasion this code comes on when I start the bike. The engine check light does not come on. According to the diagnostic codes, it has something to do with vehicle speed not being detected accurately. It will probably be quite a while til I can get the bike to the dealership but my guess is that it's not something to be overly concerned about. This happen to anybody else?
I think that's the code you get if you start the bike while rolling it backwards.
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #3 ·
Today when I started the bike I was in the garage and I know I wasn't moving, and the code appeared. Interestingly, I shut it off and waited a few minutes. On the restart there were no codes showing.
 

·
Registered
Joined
·
32 Posts
Hi sgl ,

I have the same problem . Frequently i have the folowing Diagnostic Code 84 19 on my 2014 Indian Chief Classic .

SPN 84 : Vehicle Speed Signal
FMI 19 : Received Vehicle Speed has error
 

·
Registered
Joined
·
1,749 Posts
Had it once, unfortunately I do not remember the circumstances.
 

·
Founding member
Joined
·
2,200 Posts
Today when I started the bike I was in the garage and I know I wasn't moving, and the code appeared. Interestingly, I shut it off and waited a few minutes. On the restart there were no codes showing.
If you turn the bike off, the code will be stored in the memory (can be read by Digital Wrench) but won't show on the screen. That's so you don't continue to see codes if they aren't really an issue. I agree with the above posters that it was most likely due to even slight movement (forward or backward) while the bike was started. Maybe the same reading will trigger if you shut the bike down while still moving in which case it would display the next time the bike was started?

Not sure when you had the last firmware update from your dealer, but the one that was released in December is thought to reduce the number of insignificant codes popping up. Another common one that people see is if they put the kickstand down while the bike is still running and in gear ... bike will shutdown and the code will appear on next start-up.
 

·
Registered
Joined
·
1,196 Posts
I'd rather have that code (which I have had and the kick stand down code) then the issue I had while at Sturgis.. I hit the mute button to talk.. and then I couldn't get it to unmute.. then the forward and back and volume up or down wouldn't work.. ? I'm 600 miles from home and I don't sing that well nor do I know the words to 8 hrs worth of songs.. but it works now.. so life is good..!!
 
1 - 8 of 8 Posts
Top