Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
371 Posts
Discussion Starter · #1 ·
2016 Vintage with 116/stock tune. As I toggle thru the display a check engine indication comes up. Interestingly, when checking for fault codes with my PVCX no codes appear. I go ahead and have the PVCX clear codes anyway but the check engine display remains with no codes evident.

Any ideas?
 

·
Bronze member
Joined
·
5,097 Posts
How many times have you started/stopped the bike since it appeared? The light normally takes 5 cycles to disappear. If it's a transitory code, such as a misfire on starting, and then the bike runs OK the code seems to fall off the list before that.

Sometimes I get a misfire and I think it's because the decompression mechanism takes a full turn to operate and the motor gives a little kickback on the first revolution, depending on how close to TDC a piston stops.
 

·
Registered
Joined
·
371 Posts
Discussion Starter · #3 ·
Iam at the dealer this morning for the gear position recall. Let them figure it out. Your probably right, thanks.
 

·
Bronze member
Joined
·
5,097 Posts
Good to see that they found it.

My 'learn a new thing each day' from last week was finding out that a blown headlight will make the high beam indicator flash. Was that happening?
 

·
Registered
Joined
·
371 Posts
Discussion Starter · #6 ·
No indication other than a chk eng message that kept showing up on the Vintage’s display when scrolling thru the menu (mileage, temp, fuel,voltage,etc.). All fix now, happy Indian.
 
1 - 6 of 6 Posts
Top