Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter · #1 ·
Hello Indian riders!
I have run into a minor issue with my new Chieftain and thought I'd run it by the collective and see what I might be doing wrong. I just performed the 500 mile service on my Chieftain (I serviced it myself. I've been a mechanic for over 20 years and I have trust issues :) ). For whatever reason the "Chang Oil Now" indicator keeps re-appearing after being reset once the power has been turned off. I have followed the instruction manual to the "T" and I am able to reset the Oil Life back to 100 Percent by following the manual instructions... but it's like the setting doesn't save once the bike is powered off. The next time I power the bike back on the "Change Oil Now" appears where it should display remaining Oil Life percentage. Like I said, it's a minor issue and any feedback is greatly appreciated.
 

·
Banned
Joined
·
1,841 Posts
A few of us have had the reset now come up. After resetting, it was back to normal. This is the first time I have heard of it not going away. Time for dealer intervention I think.
 

·
Registered
Joined
·
8 Posts
Omaha....I'm having exactly the same issue with the oil life reset on my 15 Chieftain. Let us know if/when you find a solution. Thx
 

·
Registered
Joined
·
113 Posts
I have the same problem after my dealer did the 500 mile work on my Roadmaster. They said they would contact Indian/Polaris about this so I am waiting to see what can be done about it.
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #5 ·
I have the same problem after my dealer did the 500 mile work on my Roadmaster. They said they would contact Indian/Polaris about this so I am waiting to see what can be done about it.
Thanks for posting. Let us know what the fix is. I'm guessing the dealer will need to flash the ECM.
 

·
Registered
Joined
·
8 Posts
I brought my 2015 Chieftain in to the shop and they could not get the problem resolved. The service manager had contacted Polaris and was told that they are aware of the issue and a fix would be included in the next software update. No ETA was provided.
 
1 - 6 of 6 Posts
Top