Indian Motorcycle Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Good day, as title states, trying my luck on a flashing brake light. Have purchased the Visi Tech Supra Brake II plug n play module for my '16 Scout Sixty. Popping the seat and trying, repeat, trying to find the plug to install said module is proving fruitless. Main harness wraps around over the battery and has an off chute running under the rear fender to the brake light unit. I CAN'T FIND THE CONNECTOR to unplug and place in this module for testing...to see if its going to have code issues with the ECM. Any help appreciated on visual location of plug. Its supposed to by plug n play instead of find n pray
 

·
Registered
Joined
·
322 Posts
The plug is inside the rear fender on the 60.
Behind the brake light bracket. I installed one about a year ago. A little tricky to get at. Make sure to use zip ties once plugged in.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Thanks for a quick reply......is the plug a 6wire to fit the supra? removing the brake light assy easier to get to plug? or should I hang rear tire off a frame jack to get fat hands in there?
 

·
Registered
Joined
·
322 Posts
9D528B97-AE90-40DF-86AF-18F8442734D1.jpeg
I tried to get a decent picture which may help. No problems with throwing codes. Setting the flash pattern took some time.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Awesome! I'll jack it up for better clearance....was that allen/phillips tool already there?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
Thanks again, rain finally stopped here in Mass, will have time on Thursday to start!
 

·
Silver member
Joined
·
4,419 Posts
I put the Visitech Supra Brake 3 on my TS111. Works like a champ. The harness is much easier to get to on the big bikes. It's under the seat!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
Aside from asking here, all sources showed under the seat also, until I couldn't find it. Now I know and will begin install soon. Thanks for all the help from this forum! Feel confident now that the ECM wont be an issue. I even mfg'd a gs100 flasher unit to tap into the line to try. Factory wiring much better'er!
 

·
Registered
Joined
·
322 Posts
Aside from asking here, all sources showed under the seat also, until I couldn't find it. Now I know and will begin install soon. Thanks for all the help from this forum! Feel confident now that the ECM wont be an issue. I even mfg'd a gs100 flasher unit to tap into the line to try. Factory wiring much better'er!
When I installed mine, I also thought it was under the seat. I emailed the company and the owner replied within minutes.
 

·
Registered
Joined
·
74 Posts
I installed one in my Sixty a year ago. Plug and play. It get plugged in under the rear fender.
 

·
Registered
Joined
·
74 Posts

·
Registered
Joined
·
467 Posts
Thought you had to use the III? Anyway I put mine in a while ago. It was easy. Like everyone else put it under the rear finder. Install is easy, set up sucked. It’s like a series of brake holds to set it where you want. I eventually got mine to flash several times every time I hit the brake. Which is what I wanted. Maybe annoying to people behind me but everytime I hit that brake they know it.
 

·
Registered
Joined
·
322 Posts
Thought you had to use the III? Anyway I put mine in a while ago. It was easy. Like everyone else put it under the rear finder. Install is easy, set up sucked. It’s like a series of brake holds to set it where you want. I eventually got mine to flash several times every time I hit the brake. Which is what I wanted. Maybe annoying to people behind me but everytime I hit that brake they know it.
Just noticed that. I installed the lll on my bike.
 
1 - 15 of 15 Posts
Top