Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Rider
Joined
·
861 Posts
Discussion Starter · #1 ·
So I have an iPod Classic (yep, before the touch screen ones came out) and for some reason it won’t play on my ride command. It says “no USB device detected”. The iPod works fine, my bike detects my iPhone XR and plays music just fine off of that, and I have a new USB cord and lightning-to-30 pin adapter but for some reason when I plug in the iPod and turn the bike on the iPod says “preparing to disconnect” and then eventually says “ok to disconnect”.
Anyways I don’t want to spend the money on a newer iPod (I want to have more music than what my phone holds) so I’m at a loss as to why it won’t work...
 

·
Registered
Joined
·
98 Posts
It’s possible due to outdated technology Ride Command just doesn’t support the iPod classic. Have you tried plugging that iPod into any recent-ish vehicles to see if it plays on that? How old of an iPod are we talking about? Is it the original one with the round pad used for navigating it?
 

·
Rider
Joined
·
861 Posts
Discussion Starter · #3 ·
It’s possible due to outdated technology Ride Command just doesn’t support the iPod classic. Have you tried plugging that iPod into any recent-ish vehicles to see if it plays on that? How old of an iPod are we talking about? Is it the original one with the round pad used for navigating it?
It’s a 6th gen so sometime after 2007...I don’t recall exactly when I got it. I can only assume that it’s too old for the RC to recognize it but my laptop and MacBook both recognize and play off it.
 

·
Registered
Joined
·
245 Posts
So I have an iPod Classic (yep, before the touch screen ones came out) and for some reason it won’t play on my ride command. It says “no USB device detected”. The iPod works fine, my bike detects my iPhone XR and plays music just fine off of that, and I have a new USB cord and lightning-to-30 pin adapter but for some reason when I plug in the iPod and turn the bike on the iPod says “preparing to disconnect” and then eventually says “ok to disconnect”.
Anyways I don’t want to spend the money on a newer iPod (I want to have more music than what my phone holds) so I’m at a loss as to why it won’t work...
Have you tried just a USB to 30 pin connector ( without using the lightning adapter) by plugging the USB into the female USB cable into the dash compartment? Im thinking the issue is the older iPod isnt liking the lightning adapter. The original cord that came with your iPod was USB to 30 pin.

Another idea to try if that doesnt work is to order a bluetooth dongle that plugs into the headphone port on the iPod. (amazon about 20 bucks or so) then simply bluetooth it to the radio.
 

·
Rider
Joined
·
861 Posts
Discussion Starter · #5 · (Edited)
Have you tried just a USB to 30 pin connector ( without using the lightning adapter) by plugging the USB into the female USB cable into the dash compartment? Im thinking the issue is the older iPod isnt liking the lightning adapter. The original cord that came with your iPod was USB to 30 pin.

Another idea to try if that doesnt work is to order a bluetooth dongle that plugs into the headphone port on the iPod. (amazon about 20 bucks or so) then simply bluetooth it to the radio.
That was the first cable that I tried. It works plugged into my computer but no bueno on the bike, that’s why I ordered the adapter in case it was the original cord.
I’m hoping to avoid adding extra gadgets, and streaming Bluetooth won’t let me control what songs are playing. Thank you for the suggestion though.
 

·
Registered
Joined
·
245 Posts
That was the first cable that I tried. It works plugged into my computer but no bueno on the bike, that’s why I ordered the adapter in case it was the original cord.
Well that sucks. Try the bluetooth dongle. I used one at work on a police scanner that couldnt be moved due to a short outside antenna lead. Plugged it into the headphone jack and then paired it with a bluetooth speaker in the patrol Lieutenants office down the hall and it works great.
 

·
Registered
Joined
·
375 Posts
The old iPad classics d ppl not work with the RC system, old tech. That said I've put my entire 8k song library on an usb stick and have it set to shuffle for care free listening....

Sent from my SM-T860 using Tapatalk
 
1 - 7 of 7 Posts
Top