Indian Motorcycle Forum banner
1 - 20 of 43 Posts

·
Registered
99 chief , 18 roadmaster, 07 roadking, 15 softail
Joined
·
80 Posts
Discussion Starter · #1 ·
Figured I should make my own thread on this project instead of cluttering one of the others I've been reading on.
Ordered from Mark at indian moto,
New plug wires
New single fire coil
Dyna 2000 ignition module
Voes kit
Rocker box gasket set(oil leak started all this)
New brake pads
Already installed new front master cylinder with lever

So here's what I had going on. The bike has about 8600 miles and I had a slight oil leak from the front rocker box.took it out to try to get rid of some fuel before I tackle doing the gaskets.at the time she ran decent maybe a bit of hesitation when ya jump on the throttle but I assumed going from my 2018 rm to this Gilroy it was just how these old motors run lol. Anyways I'm out warming it up for about 5 minutes or so and I left a stop sign and decided I would see how the old 88ci runs when its kicked hard. So as I'm going through gears 1,2,3 its strong and I get to probably 60-65mph and she just cuts out and starts backfiring and generally running like crap.i pull over and it seems to idle fine but any time I try to rev up it backfires pretty awful. I could ride very slowly so I pulled into a friend's house close by and went home to get a trailer.
At home I check fuel filter,peacock flow, good flow in the carb.cleaned float bowl(spotless already) and still runs like hell.talked with Mark about ordering random parts and he gave me a few things to check.#1 the red light no longer comes on at all on the thunderheart ignition. #2 voltage regulator puts out 13.6 idle and 14.5 reved up. #3 new plugs ,even bought a spark plug wire to change out front cylinder (plug was black up front)
So after all that he thinks ignition module took a shit,me too after all the reading I've done on these motors .
So I'll try to post progess but keep in mind I work 90-100 hours a week so it may be a few weeks.
But I promise not to disappear like I've seen alot of new members do.
And I appreciate all the members here who have taken the time to answer random questions about these topics,i think I've read them all now and feel pretty confident I can do all these items o_O
Automotive tire Motor vehicle Tire Vehicle Motorcycle
Blue Material property Font Tire Car
Blue Material property Tire Auto part Electric blue
 

·
Registered
99 chief , 18 roadmaster, 07 roadking, 15 softail
Joined
·
80 Posts
Discussion Starter · #4 ·
About to undertake the same replacement on a 2002 ghost flames spirit. Same engine same problem except I am using Ultima.

Sent from my Moto Z2 Play using Tapatalk
Feel free to post anything related here if you don't start another thread. Not sure I've seen a ghost flames spirit yet.
 

·
Registered
Joined
·
20 Posts
Will do I will find a picture of the bike. Paint was an optional upgrade in 2002. Basically camelion metalflake black and purple flames.

Sent from my Moto Z2 Play using Tapatalk
 

·
Silver member
Joined
·
5,306 Posts
It won't take you too long to do that work. First time, you're probably in for 4 hours.
 
  • Like
Reactions: Sixstring

·
Registered
Joined
·
111 Posts
I will be following your thread too and I just rebuilt the front and rear master cylinders with new pads from MOTO. I am having the same issue with the red light out on my original ignition and the bike will be running fine and it loses power and starts cutting out usually followed with a big backfire. If I return it to idle it will usually keep running but sometimes it quits and is difficult to restart. I also think it is an ignition issue so I also bought a Dyna 2000 with a VOES kit and I will hopefully be installing it next week. Good luck with your project.
 

·
Registered
Joined
·
111 Posts
I took out the original ignition module today. The red light was out but it still ran after 17000 miles and 19 years. I also ordered the upgraded coil and plug wires today from Moto. Starting back with the Dyna 2000i in the next few days.
 

·
Registered
99 chief , 18 roadmaster, 07 roadking, 15 softail
Joined
·
80 Posts
Discussion Starter · #9 ·
I've been trying to pick away at this project every chance I get but I think I work too much lol. Got the coil wired and ignition is mounted but I ran into a snag today with tools for removing my tanks.got the proper tools so hopefully tomorrow I can get back at it,long as the wife lets me be for a few hours.
 

·
Registered
99 chief , 18 roadmaster, 07 roadking, 15 softail
Joined
·
80 Posts
Discussion Starter · #11 ·
Are you having to remove your right side tank to put in a vacuum fitting?
Yeah there's no way I can get my fat hands in there,plus I'm doing new rocker box gaskets so it will be easier if I can at least remove the right side tank
 

·
Registered
Joined
·
2,820 Posts
My Shovelhead did exactly what you are describing a couple of weeks ago. Pulled good for a while, then started cutting out and wouldn't run anything much over idle, but seemed to idle fine. I pulled over and called a friend to bring a trailer. As I was waiting for him I checked a few things. I found out the positive cable at the battery was barely connected, screw had backed out. Pulled out my 10mm wrench and got it tight, started bike as buddy got there and rode it on home. Issue fixed.
 

·
Registered
99 chief , 18 roadmaster, 07 roadking, 15 softail
Joined
·
80 Posts
Discussion Starter · #15 ·
Makes total sense! Good luck tomorrow. Don't feel bad because you work so much, you will be retired some day and looking for stuff to do!
When that time comes im already thinking about what year old Indian i can build. Really like the 46-47 chiefs
My Shovelhead did exactly what you are describing a couple of weeks ago. Pulled good for a while, then started cutting out and wouldn't run anything much over idle, but seemed to idle fine. I pulled over and called a friend to bring a trailer. As I was waiting for him I checked a few things. I found out the positive cable at the battery was barely connected, screw had backed out. Pulled out my 10mm wrench and got it tight, started bike as buddy got there and rode it on home. Issue fixed.
Yeah i wish it was that simple on mine. My battery is newer even cleaned my ground and checked voltage on and off. My thought was the voltage regulator was going out from posts I had read ,but its good also.
 

·
Registered
Joined
·
111 Posts
After WW11 my Dad had an Indian Chief from that era. I would love to have a Chief but my Motorcycle window is closing down because of age. If it is something that means a lot to you go for it while you can!
 

·
Registered
99 chief , 18 roadmaster, 07 roadking, 15 softail
Joined
·
80 Posts
Discussion Starter · #17 ·
I should've built a bigger bike shop🤣
Plus every time I turn around I trip over a puppy haha.
Dog Canidae French bulldog Snout Bulldog
Motor vehicle Automotive tire Vehicle Tire Auto part
Motor vehicle Vehicle Automotive tire Auto part Car
 

·
Registered
99 chief , 18 roadmaster, 07 roadking, 15 softail
Joined
·
80 Posts
Discussion Starter · #18 ·
On a different topic, i took the trunk off the RM about a week ago and put about 500 miles on it that way. I sure do like how it looks and drives,much better handling and faster without the old lady on the back:p
Land vehicle Vehicle Motorcycle Motor vehicle Car
Land vehicle Vehicle Motor vehicle Automotive lighting Motorcycle
Land vehicle Motorcycle Vehicle Motor vehicle Automotive tire
 

·
Registered
Joined
·
111 Posts
I like the look without the trunk too! Just like I like the look of the the old Gilroys but I like the feel and HP of the new Scouts. I feel like the Gilroy Scout speaks to me and the new Scout is from another planet. Love them both!!
 
1 - 20 of 43 Posts
Top