Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
My beautiful Springfield surprised me today with an error code SPN 524080 FM31.
Cannot for the life of me find this code relating to this particular bike anywhere on the forum or Service Manual or Indian Diagnostics. Riding along peacefully home from work, came to a stop and BAM, every light on the speedo was glaring back at me as if to give me a big FU. Both turn signal indicators, ABS light, Bright light symbol, sidestand light, check engine light, chassis fault light, tire pressure light, etc. Bike didn't die out or anything and when I rolled on the throtttle at the light everything went back to normal. Pulled into the garage after another 20 miles or so and it did it again. This has me concerned. I already checked battery terminals and ground for tightness. Any insight as to what may be causing this would be appreciated. Perplexed to say the least. Thanks forum.
 

·
Registered
Joined
·
9 Posts
Indian diagnostic mobile app states: Cruise control input message counter. Counter not incremented.

Can't provide any help beyond that info.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #3
Must have missed that or typed in a wrong #. Thank you.

Sent from my SM-G975U using Tapatalk
 

·
Registered
Joined
·
343 Posts
Curious to what you found was wrong. Sounds like a strange error code.
 

·
Registered
Joined
·
1,078 Posts
Strange question, but have you done any light swaps? I’ve had a lightbulb that caused a freak cruise control error because the bulb was screwing with the whole electrical system.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #6
Cameroni79, you nailed it my friend. Swapped out the halogens for LED's a while back, guessing the compatibility isn't there with the CANBUS. Strange that the error was just showing up after they had been in for 6 months. Anyway, new headlight ordered. Will install next week. Good call.
 

·
Registered
Joined
·
1,078 Posts
Cameroni79, you nailed it my friend. Swapped out the halogens for LED's a while back, guessing the compatibility isn't there with the CANBUS. Strange that the error was just showing up after they had been in for 6 months. Anyway, new headlight ordered. Will install next week. Good call.
You just made my day! Very glad that it was something simple.
 

·
Registered
Joined
·
1 Posts
Cameroni79, you nailed it my friend. Swapped out the halogens for LED's a while back, guessing the compatibility isn't there with the CANBUS. Strange that the error was just showing up after they had been in for 6 months. Anyway, new headlight ordered. Will install next week. Good call.
Just wondering since im planning on replacing my halogens with aftermarket led, any that you recommend or avoid?
Thanks
 

·
Registered
Joined
·
343 Posts
I had experience with a cheaper set of Chinese LED’s and while they looked brighter looking at the bike, they were horrible. LED’s seem to have a sharp cut off line that really messes you up going around a corner. I went back to the stock halogen and it’s way better. I think I may replace the bulb itself next time with a better halogen but unless you’re paying big bucks for a name brand LED I think they’re worthless. But this is just my opinion and my experience, so take it as a grain of salt...
 
1 - 9 of 9 Posts
Top