Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
my bike keeps going dead at idle 3 out of 10 times you stop to idle the bike will shut off it will start back up after the process been in shop twice changed fuel pump the first time but still doing same thing any one experienced this problem
 

·
Registered
Joined
·
604 Posts
Got a 2019 RM too. I can't say that I have experienced this, and hope I don't too. For anyone for that matter. Have you toggled the cylinder deactivation off or on for comparison? You can do so in the settings from the Ride Command. I have noticed sometimes the idle will kind of hiccup going in and out of cylinder deactivation and the idle will jump. But I think some how only once the bike actually died on me I started it right up and started going immediately. So it wasn't hot enough for the deactivation or anything. But I have not turned off the cylinder deactivation, it will still automatically cut off when it's at whatever temperature and the little icon will appear on the RC screen. Feel free to post in the welcome forum too, but welcome anyways from SE PA!
 

·
Registered
Joined
·
34 Posts
my bike keeps going dead at idle 3 out of 10 times you stop to idle the bike will shut off it will start back up after the process been in shop twice changed fuel pump the first time but still doing same thing any one experienced this problem
My new RM was doing a similar thing. It acted/sounded like it ran out of gas. Idle was around 650-750 rpm. I only have 2,000 miles but almost every ride is 250 miles +/- and starting elevation is 5,000' and climb to 10,000' and return home.
I feel like the bike has finally sorted itself out. I'm pushing 50 MPG averaging 50 MPH and know my bike was way to lean. I don't know if this helps but that's my $.02
 

·
Registered
Joined
·
604 Posts
Maybe the high elevation with the lean set up causing it then? But if it feels better then that's good!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
My new RM was doing a similar thing. It acted/sounded like it ran out of gas. Idle was around 650-750 rpm. I only have 2,000 miles but almost every ride is 250 miles +/- and starting elevation is 5,000' and climb to 10,000' and return home.
I feel like the bike has finally sorted itself out. I'm pushing 50 MPG averaging 50 MPH and know my bike was way to lean. I don't know if this helps but that's my $.02
Thanks for info but mine has nothing to do with elevation
 

·
Registered
Joined
·
382 Posts
Thanks for info but mine has nothing to do with elevation
When I bought my 2018 I actually test drove a 2019. I loved the dark horse I drove but it died on me twice and since the dealership started the bike for me and they didnt tell me about the cylinder deactivation I could not get the bike started. I was in Houston traffic and had to push the bike off the road twice. And finally got it started due to not being in neutral or the kick stand was down I dont remember what the case was. But first ride startled me a bit. I think it had to do with the cylinder deactivation. Good luck hope you get it sorted out
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
When I bought my 2018 I actually test drove a 2019. I loved the dark horse I drove but it died on me twice and since the dealership started the bike for me and they didnt tell me about the cylinder deactivation I could not get the bike started. I was in Houston traffic and had to push the bike off the road twice. And finally got it started due to not being in neutral or the kick stand was down I dont remember what the case was. But first ride startled me a bit. I think it had to do with the cylinder deactivation. Good luck hope you get it sorted out
Thanks
 
1 - 7 of 7 Posts
Top