Indian Motorcycle Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
Rode the Scout to work today, first time out in darker conditions.
Bulb in the speedo went out, had to rely on streetlights & traffic flow for speed.

What type of bulb does it take & how is it accessed?

Thanks
 

·
Registered
Joined
·
80 Posts
Recently replaced my burned out speedo bulb on my '01 Chief. Electric speedo, not mechanical.

If it's the same, you should be able to gently pull/pry the speedo out of it's home in the console.

The bulb stats are printed on the base of the bulb. I used a red LED bulb that had the same stats. Popped it all back in, and has been working fine. If you run with a stock replacement, it uses a red sleeve (bulb condom?) to make it shed red light. Mine shredded when removing it.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #3 ·
I don't see any way to shimmy the speedo out. I pulled the 1 bolt in the 'dash' and the trim didn't seem to budge.
Does the entire panel between the split tank need to be removed to get to the back of the speedo?

Not my photo, but here is the Scout 'dash', removing the 1 bolt here didn't seem to do anything. Didn't try to remove the bolt down by the seat.
 

·
Registered
Joined
·
80 Posts
Mine just pried out with my finger nails. ? Maybe try a plastic putty knife.

Make sure you loc-tite those dash screws before riding. They will back out on you from vibration.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #5 ·
Got it pulled apart. Had to remove both dash bolts & get it lifted enough to disconnect the speedo cable.
No idea what the replacement bulb is though.
Searching online, a #74 wedge seems close.
It looks like the socket only contacts 1 lead on the bulb.

 

·
Registered
Joined
·
86 Posts
Discussion Starter · #6 ·
Moot point. Checked & not getting power to the bulb. Need to try to figure out where the wire gets power.
 

·
Registered
Joined
·
80 Posts
I'm glad you figured out as much as you did. Sorry I couldn't be of any help. My speedo is electronic, not mechanical. ?

I took a look at Indian Moto, and didn't see the bulb to replace yours. I hope you figure out where the power is interrupted, and that's all you need.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #8 ·
Yeah, I saw they sell a replacement kit, new wire/socket & bulb. May have to go that route. For now, not being out outside daylight hours will have to suffice.
 

·
Registered
Joined
·
25 Posts
Go on line and buy some LED lites. They make them in 12v without a resister and various sizes and colors and CHEAP ! I put one in my speedo and fender lite.Work great and they will last forever.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #10 ·
Will need to trace the wire & find where it's losing power.
Multimeter is showing nothing at the socket.
That, or run a new wire for the speedo bulb.

Guessing I'll need to empty/pull the tank to get to the wiring. Seemed awful tight in there when I pulled the 'dash'
 

·
Registered
Joined
·
20 Posts
Having the same problem no power to the speedometer did you find out where the problem was at with the wiring or what did you come up with your help would be greatly appreciated
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #12 ·
No, bike made its way back to my in-law's garage, so I never got around to trying to trace down the issue.
 

·
Registered
Joined
·
1 Posts
2001 Scout same no power to the speedo light nor the fender light. Disconnected the speedo cable and the lights came back on. As soon as the drive cable touches the speedo housing lights go out. So far no luck finding the problem.
 
1 - 13 of 13 Posts
Top